PowerStore: System Health Checks detects a stale SCSI3 reservation issue

Summary: This System Health Check (SHC) to detect if a system with PowerStoreOS version 4.0.x is affected with the stale SCSI3 reservation issue. For details on this issue, see KB# 000234421.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

System Health may display a Found Volumes with scale SCSI3 reservation (KB#000234421) message in one of the following scenarios:
 

  • Running a System Check using PowerStore Manager (GUI) with the Run System Check option:
Stale SCSI3 reservation detected
  • Running the System Health Service Script (svc_health_check) using an SSH connection:
[SVC:service@50T1BW2-A user]$ svc_health_check run -rhc stale_scsi3_reservation_check
Name                               Location  Status     Description
Stale SCSI3 reservation check      node_b    Failed     Found volumes with stale SCSI3 reservation.(KB#000234421)
 
 
SUMMARY Status: Failed
   Passed:      0
   Failed:      1
   Total:       1

   
Note: Results may vary based on the node where the check failed.
 
For further details on the SCSI3 stale reservation issue that is detected by this SHC check, see KB# 000234421 PowerStore: Invalid SCSI-3 reservations and registrations may cause a software upgrade to PowerStoreOS 4.0.0.x to fail
 
The health check is an off-release SHC check that is contained in the Health Check thin package. See the Additional Info section of this article for information about the Health Check thin package.

Cause

Appliances running PowerStoreOS version 3.6 or earlier version may have SCSI3 reservation with invalid or mismatch SCSI registration

During NDU to version 4.0.x of such appliances, NDU may fail if the owner_idx has no corresponding SCSI reg object. However, if the owner_idx is reused (even if it is for a different volume), NDU to 4.0.x will succeed. In such scenario, when system runs on version 4.0.x code, the invalid or mismatch SCSI registration may cause a System Manager (SYM) rolling panic condition.

Resolution

To resolve this issue, contact technical support for assistance. Reference KB# 000234421 for expedited attention and resolution.

Additional Information

Affected Products

PowerStore
Article Properties
Article Number: 000259473
Article Type: Solution
Last Modified: 14 Jun 2025
Version:  2
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