PowerStore: Health Check Detect Node har pladeallokering over skbuff_fclone_cache grænse

Summary: Disse kontroller er designet til at registrere, om en node har en SLAB-allokering, der ligger over skbuff_fclone_cache grænsen. "off_release_check_kernel_slab_memory_failed" (Pre-Upgrade Health Check) "" stopper opgraderingen på en klynge, der kører PowerStoreOS 3.x og 4.0.x, hvis der registreres et sådant problem. Systemtilstandskontrol (SHC) 'kernel_slab_check" mislykkes, hvis dette problem findes på en klynge, der kører PowerStoreOS 3.x og 4.0.x. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerStore Pre-Upgrade Health Check (PUHC) og System Health Check (SHC) registrerer muligvis dette problem, når de køres på følgende PowerStoreOS-versioner:

  • PowerStoreOS 3.x
  • PowerStoreOS 4.0.x
MEDDELELSE
Det problem, der blev registreret under disse kontroller, er løst i PowerStoreOS version 4.0.1.2 (eller nyere) og 3.6.1.5 (eller nyere 3.6.x-versioner).
  • Derfor er denne PUHC indstillet til kun at registrere dette problem ved opgradering fra version 3.0.0 til 3.6.1.4 og fra version 4.0.0 til 4.0.1.1.


Scenarie 1:
Følgende meddelelse observeres muligvis før en opgradering fraPowerStoreOS-versionerne 3.0.0 til 3.6.1.4 og fraversion 4.0.0 til 4.0.1.1, når du kører PUHC:

The available system memory or skbuff_fclone_cache is below threshold (KB 000261124). Please contact your service provider. (off_release_check_kernel_slab_memory_failed)

off release check kernel slab memory PUHC check mislykkedes

Scenarie 2:
Følgende meddelelse kan observeres på en PowerStoreOS 3.x- eller 4.0.x-klynge, når du kører SHC:

Kernel memory allocation is over the limit. (KB 000261124)

 Hvis skbuff fclone cache nåede sin grænse 

  • Hvis testen af systemtilstandskontrol (SHC) udføres fra CLI (Command Line Interface), vises følgende muligvis:
[BSC:cyc@ABCDEFG-A cyc]$ svc_health_check run -rhc kernel_slab_check
/usr/lib/python2.7/site-packages/requests/__init__.py:91: RequestsDependencyWarning: urllib3 (1.26.18) or chardet (3.0.4) doesn't match a supported version!
  RequestsDependencyWarning)
Name                               Location  Status     Description
OS kernel memory allocation check  node_a    Failed     Kernel memory allocation is over the limit. (KB 000261124)
OS kernel memory allocation check  node_b    Passed


SUMMARY Status: Failed
   Passed:      1
   Failed:      1
   Total:       2
[BSC:cyc@ABCDEFG-A cyc]$

 
[BSC:cyc@ABCDEFG-B ~]$ svc_health_check run -rhc kernel_slab_check
/usr/lib/python2.7/site-packages/requests/__init__.py:91: RequestsDependencyWarning: urllib3 (1.26.18) or chardet (3.0.4) doesn't match a supported version!
  RequestsDependencyWarning)
Name                               Location  Status     Description
OS kernel memory allocation check  node_a    Failed     Kernel memory allocation is over the limit. (KB#000261124)
OS kernel memory allocation check  node_b    Passed


SUMMARY Status: Failed
   Passed:      1
   Failed:      1
   Total:       2

 

Resultaterne kan variere afhængigt af den node, hvor kontrollen mislykkedes.

Disse helbredstjek er PUHC- og SHC-kontroller uden frigivelse, som findes i den tynde pakke til sundhedstjekket. Denne pakke kan downloades fra Dells websted Drivere og downloads .

Se afsnittet Yderligere oplysninger for at få oplysninger om den tynde pakke til sundhedstjekket.

Cause

En node kan støde på en kernepanik på grund af en OOM-tilstand (Out-Of-Memory). Dette problem skyldes et højt hukommelsesforbrug på skbuff_fclone_cache fra SLAB.

Resolution

Du kan løse dette problem ved at kontakte Dells tekniske support for at få hjælp. Nævn denne artikel for hurtig opmærksomhed og løsning.

Additional Information

Affected Products

PowerStoreOS
Article Properties
Article Number: 000261124
Article Type: Solution
Last Modified: 27 Oct 2025
Version:  10
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.