Dell NativeEdge: Falha no download do catálogo com "Internal Server Error"

Summary: No NativeEdge Orchestrator 3.0.0.0, o download do catálogo pode falhar com "Internal Server Error"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

No NativeEdge Orchestrator 3.0.0.0, um novo recurso é introduzido para fazer download direto de modelos e plug-ins no NativeEdge Orchestrator em um ambiente não airgapped. Você pode observar "erro interno do servidor" ao tentar fazer download de plug-ins maiores em tamanho. 

Erro interno do servidor ao fazer download de um plug-in grande

Se você examinar os logs de rede usando a ferramenta de desenvolvedor do navegador, poderá ver "500 internal server error"

Erro 500 ao visualizar pela ferramenta de desenvolvedor do navegador

Cause

Isso acontece quando um download leva mais de 30 segundos para ser concluído. Os logs no back-end do estágio geram o erro abaixo. 

message: 
"Requested URL: /plugins?title=Nativeedge%20Gcp%20Plugin&visibility=tenant&package_name=nativeedge-gcp-plugin&plugin_archive_url=https%3A%2F%2Fdownloads.dell.com%2FFOLDER12410532M%2F1%2Fnativeedge-gcp-plugin_1.10.10.0_J34CH.wgn ECONNABORTED timeout of 30000ms exceeded" 

Resolution

O "500 internal server error" é um alarme falso. O arquivo do plug-in é baixado com sucesso na maioria dos casos. 

Os usuários podem atualizar a interface de "Download from Catalog". O plug-in baixado é exibido corretamente.

Como atualizar a interface do usuário do catálogo

Se, em qualquer caso, a solução temporária acima não funcionar, entre em contato com o suporte Dell para obter mais soluções de problemas. 

A correção estará disponível na versão futura do NativeEdge. 

Affected Products

NativeEdge Solutions, NativeEdge
Article Properties
Article Number: 000261316
Article Type: Solution
Last Modified: 22 Apr 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.