NetWorker: Daten können nicht von vCenter abgerufen werden: SSL_ERROR_SYSCALL Von der zugrunde liegenden SSL/TLS-BIO beobachteter Fehler

Summary: Der VMware-Bestandsaufnahmeprozess des NetWorker-Servers meldet "Daten aus vCenter können nicht abgerufen werden: SSL_ERROR_SYSCALL Von zugrunde liegendem SSL beobachteter Fehler? TLS-BIOGRAFIE: Kein Fehler." ...

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Symptoms

  • Die folgende Fehlermeldung wird in der NetWorker Management Console (NMC) zurückgegeben, wenn eine VMware View-Aktualisierung durchgeführt wird:

NMC VMware View-Aktualisierungsfehler

  • Die Versionen von NetWorker-Server und vCenter Server erfüllen die Kompatibilitätsanforderungen. Weitere Informationen finden Sie in der NetWorker-Kompatibilitätsmatrix, die verfügbar ist unter: https://elabnavigator.dell.com/eln/modernHomeAutomatedTiles?page=NetWorker
  • Der NetWorker-Server kann die IP-Adresse, den vollständig qualifizierten Domainnamen (FQDN) und den Kurznamen von vCenter korrekt auflösen.
nslookup ADDRESS
  • Der NetWorker-Server kann Port 443 auf dem vCenter Server erreichen:

Linux:

curl -v vCenter_Address:443
Windows (PowerShell):
Test-NetConnection -ComputerName vCenter_Address -port 443

Cause

Firewallkonfiguration: Stellen Sie sicher, dass Ihre Firewall den SSL-Datenverkehr nicht blockiert. Selbst wenn Port 443 offen ist, verhindert die Filterung auf Paketebene möglicherweise den SSL-Datenverkehr.

Netzwerkprobleme: Der Fehler kann auf ein Netzwerkproblem zurückzuführen sein, bei dem die Verbindung vom Peer zurückgesetzt wird. Dies kann auftreten, wenn ein Zwischengerät (z. B. eine Firewall oder ein Router) die Verbindung stört.

Der SSL_ERROR_SYSCALL Fehler tritt auf, wenn der TCP-Handshake abgeschlossen ist, aber ein TCP-Reset-Paket (RST) empfangen wird, wodurch die Verbindung während der SSL-Phase beendet wird.

Resolution

Der Netzwerk- oder Firewalladministrator muss prüfen, ob Firewallregeln SSL-Verbindungen zwischen dem NetWorker-Server und vCenter Server auf Port 443 blockieren oder unterbrechen. Wenn Regeln vorhanden sind, deaktivieren Sie sie vorübergehend, um festzustellen, ob das Problem in NetWorker behoben wurde. Wenn die Deaktivierung der Regeln es VMware View ermöglicht, zu aktualisieren und Backups abzuschließen, passen Sie die Firewall- oder Routingregeln an, um die Verbindungen zwischen dem NetWorker-Server und vCenter aufrechtzuerhalten.
 

Tools zur Paketerfassung


Der Netzwerkadministrator kann auch Paketerfassungstools (tcpdump, Wireshark) vom NetWorker-Server und vCenter. Wenn das Problem reproduziert wird, überprüfen Sie die Paketerfassungen, um festzustellen, ob der vCenter Server die Bestandsaufnahmesitzung schließt.

tcpdump Befehlsbeispiel:

nohup tcpdump -i any -s 0 -C 500 -w /tmp/`hostname`_`date -I`.pcap &
  • nohup gibt an, dass der Befehl im Hintergrund ausgeführt wird, bis die Prozess-ID (PID) mit dem Befehl kill .
  • -i Gibt die Schnittstelle an, die Sie verwenden können anyoder geben Sie einen Netzwerkschnittstellennamen an, z. B. eth0.
  • -s 0 gibt eine Fanglänge von 65535 an (der gesamte Frame wird erfasst).
  • -C 500 Gibt eine Dateigröße von 500.000.000 Byte an.
  • -w Gibt den Speicherort der Ausgabedatei an. Die angezeigte Ausgabedatei wird automatisch mit dem Systemhostnamen und JJJJ-MM-TT erzeugt, mit dem sie ausgeführt wurde. Eine .pcap-Datei kann in Wireshark analysiert werden.
Linux NetWorker-Server und vCenter Server: https://www.tcpdump.org/manpages/tcpdump.1.html Dieser Hyperlink führt Sie zu einer Website außerhalb von Dell Technologies.


Beispiel für den Befehl Wireshark tshark:

HINWEIS: Die Wireshark-Benutzeroberfläche kann auch (anstelle von Tshark) verwendet werden, um die Paketerfassung zu erstellen, wenn eine Benutzeroberfläche bevorzugt wird.
1. Wireshark muss auf dem System einschließlich des tshark-Pakets installiert sein.
2. Öffnen Sie eine Administratorbefehls-/PowerShell-Eingabeaufforderung.
3. Verwenden Sie den Befehl change directory (cd), um zum Wireshark-Installationspfad zu wechseln (z. B.: C:\Programme\Wireshark)
cd "C:\Program Files\Wireshark"
4. Rufen Sie die Netzwerkschnittstellen-Geräte-IDs ab, indem Sie Folgendes ausführen:
.\tshark.exe -D
5. Führen Sie tshark mit der folgenden Syntax aus:
.\tshark.exe -i{Interface Number} -a files:{number of files} -b duration:{file duration in seconds} -f "dst host DST_IP_ADDRESS and src host SRC_IP_ADDRESS" -w tshark_capture.pcapng

DST_IP_ADDRESS: Ersetzen Sie diese durch die auflösbare DNS-IP-Adresse des vCenter Servers. Dies sollte die auflösbare DNS-IP-Adresse für den vCenter-Hostnamen sein, der zum Hinzufügen des vCenter-Servers zu NetWorker verwendet wird.
SRC_IP_ADDRESS: Ersetzen Sie diese durch die auflösbare DNS-IP-Adresse des NetWorker-Servers.

Beispiel:
TSHARK-Beispiel
Siehe: https://www.wireshark.org/docs/man-pages/tshark.html Dieser Hyperlink führt Sie zu einer Website außerhalb von Dell Technologies.


Verfahren:


Welche Methode zur Paketerfassung verwendet wird, hängt von den beteiligten Betriebssystemen ab. Verwenden Sie für Windows NetWorker-Server Wireshark oder tshark wie oben beschrieben. Verwenden Sie für Linux NetWorker-Server und die vCenter Server Appliance tcpdump wie oben beschrieben.

  1. Starten Sie eine Paketerfassung auf dem NetWorker-Server und auf dem vCenter Server. Dadurch muss der Kommunikationsversuch zwischen dem NetWorker-Server und vCenter Server erfasst werden.
  2. Führen Sie über die NetWorker Management Console (NMC) eine VMware View-Aktualisierung durch.
    1. Gehen Sie zu Protection –> VMware View
    2. Klicken Sie mit der rechten Maustaste auf den vCenter Server.
    3. Klicken Sie auf Aktualisieren.
  3. Wenn der SSL_ERROR_SYSCALL-Fehler angezeigt wird. Notieren Sie sich die Uhrzeit auf dem NetWorker-Server und auf dem vCenter Server.
  4. Beenden Sie die Paketerfassung.
  5. Überprüfen Sie die Paketerfassungen auf TCP-Reset-Pakete (RST) zwischen dem NetWorker-Server und vCenter Server. 

Beachten Sie:

  • Die auflösbare DNS-IP-Adresse des NetWorker-Servers und des vCenter-Servers.
  • Die Zeitzonen des NetWorker-Servers und des vCenter Servers (falls unterschiedlich).
  • Der Zeitstempel auf dem NetWorker-Server, als der SSL_ERROR_SYSCALL in der NMC angezeigt wurde.
HINWEIS: Dies muss vom Netzwerkadministrator oder -team des Standorts überprüft werden.

Additional Information

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000272007
Article Type: Solution
Last Modified: 28 Jan 2025
Version:  1
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