NetWorker: No se pueden obtener datos de vCenter: SSL_ERROR_SYSCALL Error observado en el BIOS de SSL/TLS subyacente

Summary: El proceso de inventario de VMware del servidor NetWorker informa "No se pueden obtener datos de vCenter: SSL_ERROR_SYSCALL Error observado por el SSL subyacente? BIOS de TLS: No hay errores". ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Se muestra el siguiente mensaje de error en NetWorker Management Console (NMC) cuando se realiza una actualización de VMware View:

Error de actualización de VMware View de NMC

nslookup ADDRESS
  • NetWorker Server puede comunicarse con el puerto 443 en vCenter Server:

Linux:

curl -v vCenter_Address:443
Windows (PowerShell):
Test-NetConnection -ComputerName vCenter_Address -port 443

Cause

Configuración del firewall: Asegúrese de que su firewall no esté bloqueando el tráfico SSL. Incluso si el puerto 443 está abierto, es posible que el filtrado a nivel de paquetes impida el tráfico SSL.

Problemas de red: El error puede deberse a un problema de red en el que el par está restableciendo la conexión. Esto puede suceder si hay un dispositivo intermedio (como un firewall o enrutador) que interfiere con la conexión.

El error SSL_ERROR_SYSCALL se produce cuando se completa el protocolo de enlace TCP, pero se recibe un paquete de restablecimiento TCP (RST), lo que finaliza la conexión durante la fase SSL.

Resolution

El administrador de la red o del firewall debe comprobar si hay reglas de firewall que bloqueen o interrumpan las conexiones SSL entre NetWorker Server y vCenter Server en el puerto 443. Si existen reglas establecidas, deshabilítelas temporalmente para ver si el problema se resuelve en NetWorker. Si la deshabilitación de las reglas permite que VMware View se actualice y que se completen los respaldos, ajuste las reglas de firewall o enrutamiento para mantener las conexiones entre NetWorker Server y vCenter.
 

Herramientas de captura de paquetes


El administrador de red también puede utilizar herramientas de captura de paquetes (tcpdump, Wireshark) desde NetWorker Server y vCenter. Cuando se reproduzca el problema, revise las capturas de paquetes para ver si vCenter está cerrando la sesión de inventario.

tcpdump Ejemplo de comando:

nohup tcpdump -i any -s 0 -C 500 -w /tmp/`hostname`_`date -I`.pcap &
  • nohup indica que el comando se ejecuta en segundo plano hasta que el ID de proceso (PID) finalice con el kill comando.
  • -i Especifica la interfaz, puede usar anyo especifique un nombre de interfaz de red, como eth0.
  • -s 0 especifica una longitud de instantánea de 65535 (se captura todo el fotograma).
  • -C 500 indica un tamaño de archivo de 500 000 000 bytes.
  • -w indica la ubicación del archivo de salida. El archivo de salida que se muestra se genera automáticamente con el nombre de host del sistema y AAAA-MM-DD que se ejecutó. Un archivo .pcap se puede analizar en Wireshark.
NetWorker Server de Linux y vCenter Server: https://www.tcpdump.org/manpages/tcpdump.1.html Este hipervínculo lo redirige a un sitio web fuera de Dell Technologies.


Ejemplo de comando Wireshark tshark:

NOTA: También se puede utilizar la interfaz de usuario de Wireshark (en lugar de tshark) para crear la captura de paquetes si se prefiere una interfaz de usuario.
1. Wireshark debe estar instalado en el sistema, incluido el paquete tshark.
2. Abra un símbolo del sistema de Comando de administrador/PowerShell.
3. Utilice el comando change directory (cd) para ir a la ruta de instalación de Wireshark (por ejemplo: C:\Archivos de programa\Wireshark)
cd "C:\Program Files\Wireshark"
4. Obtenga los ID de dispositivo de interfaz de red mediante la ejecución del siguiente comando:
.\tshark.exe -D
5. Ejecute tshark con la siguiente sintaxis:
.\tshark.exe -i{Interface Number} -a files:{number of files} -b duration:{file duration in seconds} -f "dst host DST_IP_ADDRESS and src host SRC_IP_ADDRESS" -w tshark_capture.pcapng

DST_IP_ADDRESS: Reemplace esto por la dirección IP que se puede resolver por DNS del servidor vCenter. Esta debe ser la dirección IP que se puede resolver por DNS para el nombre de host de vCenter utilizado para agregar el vCenter Server a NetWorker.
SRC_IP_ADDRESS: Reemplace esto por la dirección IP que se puede resolver por DNS del servidor NetWorker Server.

Ejemplo:
Ejemplo de tshark
Véase: https://www.wireshark.org/docs/man-pages/tshark.html Este hipervínculo lo redirige a un sitio web fuera de Dell Technologies.


Procedimiento:


El método de captura de paquetes utilizado depende de los sistemas operativos involucrados. En el caso de los servidores NetWorker de Windows, utilice Wireshark o tshark como se detalla anteriormente. Para los servidores Linux NetWorker y el dispositivo del servidor de vCenter, utilice tcpdump como se indicó anteriormente.

  1. Inicie una captura de paquetes en NetWorker Server y en vCenter Server. Esto debe capturar el intento de comunicación entre NetWorker Server y vCenter Server.
  2. En NetWorker Management Console (NMC), realice una actualización de VMware View.
    1. Vaya a Protection-VMware> View
    2. Haga clic con el botón secundario en vCenter Server.
    3. Haga clic en Actualizar.
  3. Cuando aparece el SSL_ERROR_SYSCALL error. Tome nota de la hora en NetWorker Server y vCenter Server.
  4. Detenga las capturas de paquetes.
  5. Revise las capturas de paquetes para ver si hay paquetes de restablecimiento TCP (RST) entre NetWorker Server y vCenter Server. 

Toma nota de lo siguiente:

  • La dirección IP que se puede resolver por DNS de NetWorker Server y vCenter Server.
  • Las zonas horarias de NetWorker Server y vCenter Server (en caso de que sean diferentes).
  • El registro de fecha y hora en NetWorker Server cuando el SSL_ERROR_SYSCALL apareció en NMC.
NOTA: Esto debe ser revisado por el administrador de red o el equipo del sitio.

Additional Information

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000272007
Article Type: Solution
Last Modified: 28 Jan 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.