NetWorker: Не вдається отримати дані з vCenter: SSL_ERROR_SYSCALL Помилка, що спостерігається за допомогою BIO SSL/TLS

Summary: Звіт про процес інвентаризації VMware сервера NetWorker «Не вдається отримати дані з vCenter: SSL_ERROR_SYSCALL Помилка спостерігається за допомогою базового SSL? БІОГРАФІЯ TLS: Жодної помилки». ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Наступне повідомлення про помилку повертається в консолі управління NetWorker (NMC) під час виконання оновлення VMware View:

Помилка оновлення перегляду NMC VMware

  • Версії NetWorker server і vCenter Server відповідають вимогам сумісності. Перегляньте матрицю сумісності NetWorker, доступну за посиланням: https://elabnavigator.dell.com/eln/modernHomeAutomatedTiles?page=NetWorker
  • Сервер NetWorker може правильно розпізнавати IP-адресу vCenter, повністю кваліфіковане доменне ім'я (FQDN) і коротке ім'я.
nslookup ADDRESS
  • Сервер NetWorker може досягати порту 443 на сервері vCenter:

Linux:

curl -v vCenter_Address:443
Windows (PowerShell):
Test-NetConnection -ComputerName vCenter_Address -port 443

Cause

Конфігурація брандмауера: Переконайтеся, що ваш брандмауер не блокує трафік SSL. Навіть якщо порт 443 відкритий, фільтрація на рівні пакетів може перешкоджати трафіку SSL.

Проблеми з мережею: Помилка може бути пов'язана з проблемою з мережею, коли з'єднання скидається одноранговим вузлом. Це може статися, якщо є проміжний пристрій (наприклад, брандмауер або маршрутизатор), який заважає з'єднанню.

Помилка SSL_ERROR_SYSCALL виникає, коли TCP-рукостискання завершується, але надходить пакет скидання TCP (RST), який завершує з'єднання під час фази SSL.

Resolution

Адміністратор мережі або брандмауера повинен перевірити наявність правил брандмауера, які блокують або переривають SSL-з'єднання між сервером NetWorker і сервером vCenter на порту 443. Якщо є якісь правила, тимчасово вимкніть їх, щоб перевірити, чи вирішено проблему в NetWorker. Якщо вимкнення правил дозволяє VMware View оновлюватися та виконувати резервні копії, налаштуйте брандмауер або правила маршрутизації для підтримки з'єднань між сервером NetWorker та vCenter.
 

Інструменти для захоплення пакетів


Адміністратор мережі також може використовувати інструменти для перехоплення пакетів (tcpdump, Wireshark) з сервера NetWorker і vCenter. Коли проблема відтворюється, перегляньте захоплення пакета, щоб побачити, чи закриває сервер vCenter сеанс інвентаризації.

tcpdump Приклад команди:

nohup tcpdump -i any -s 0 -C 500 -w /tmp/`hostname`_`date -I`.pcap &
  • nohup вказує на те, що команда виконується у фоновому режимі, доки ідентифікатор процесу (PID) не буде завершено за допомогою кнопки kill команда.
  • -i вказує інтерфейс, ви можете використовувати anyабо вкажіть ім'я мережевого інтерфейсу, наприклад ETH0.
  • -s 0 вказує довжину знімка 65535 (захоплюється весь кадр).
  • -C 500 Параметр вказує розмір файлу 500 000 000 байт.
  • -w Параметр вказує місце розташування вихідного файлу. Показаний файл результату буде автоматично створено з іменем системного хосту та РРРР-ММ-ДД, на якому його було запущено. Файл .pcap можна проаналізувати в Wireshark.
Сервер Linux NetWorker і сервер vCenter: https://www.tcpdump.org/manpages/tcpdump.1.html Це гіперпосилання веде вас на веб-сайт за межами Dell Technologies.


Приклад команди Wireshark tshark:

ПРИМІТКА. Інтерфейс користувача Wireshark також можна використовувати (замість tshark) для створення захоплення пакетів, якщо ви віддаєте перевагу інтерфейсу користувача.
1. Wireshark повинен бути встановлений в системі, включаючи пакет tshark.
2. Відкрийте запит команди адміністратора/PowerShell.
3. Використовуйте команду change directory (cd), щоб перейти до шляху встановлення Wireshark (наприклад: C:\Program Files\Wireshark)
cd "C:\Program Files\Wireshark"
4. Щоб отримати ідентифікатори пристроїв мережевого інтерфейсу, виконайте такі дії:
.\tshark.exe -D
5. Запустіть tshark, використовуючи наступний синтаксис:
.\tshark.exe -i{Interface Number} -a files:{number of files} -b duration:{file duration in seconds} -f "dst host DST_IP_ADDRESS and src host SRC_IP_ADDRESS" -w tshark_capture.pcapng

DST_IP_ADDRESS: Замініть це на DNS-розпізнавальну IP-адресу сервера vCenter. Це має бути IP-адреса DNS, яку можна вирішити, для імені хоста vCenter, який використовується для додавання сервера vCenter до NetWorker.
SRC_IP_ADDRESS: Замініть це на DNS-розпізнавальну IP-адресу сервера NetWorker.

Приклад:
Приклад TSHARK
Дивіться: https://www.wireshark.org/docs/man-pages/tshark.html Це гіперпосилання веде вас на веб-сайт за межами Dell Technologies.


Процедура:


Використовуваний метод захоплення пакетів залежить від задіяних операційних систем. Для серверів Windows NetWorker використовуйте Wireshark або tshark , як описано вище. Для серверів Linux NetWorker та серверного пристрою vCenter використовуйте tcpdump , як описано вище.

  1. Запустіть захоплення пакетів як на сервері NetWorker, так і на сервері vCenter. Він повинен фіксувати спробу зв'язку між сервером NetWorker і сервером vCenter.
  2. З консолі управління NetWorker (NMC) виконайте оновлення VMware View.
    1. Перейдіть до Protection-VMware> View
    2. Клацніть правою кнопкою миші сервер vCenter.
    3. Натисніть Оновити.
  3. При появі помилки SSL_ERROR_SYSCALL. Запишіть час на сервері NetWorker і сервері vCenter.
  4. Зупинка захоплення пакета.
  5. Перегляньте захоплення пакетів для будь-яких пакетів скидання TCP (RST) між сервером NetWorker і сервером vCenter. 

Зверніть увагу на:

  • DNS-адреса сервера NetWorker і сервера vCenter.
  • Часові пояси як сервера NetWorker, так і сервера vCenter (у випадку різні).
  • Позначка часу на сервері NetWorker, коли SSL_ERROR_SYSCALL з'явився в NMC.
ПРИМІТКА. Це має бути перевірено адміністратором мережі або командою сайту.

Additional Information

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000272007
Article Type: Solution
Last Modified: 28 Jan 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.