NVP-vProxy: Registrierung schlägt fehl "Anmeldung bei vCenter nicht möglich ... Falscher Nutzername oder falsches Kennwort"

Summary: Die Registrierung eines NetWorker VMware Protection (NVP) vProxy schlägt fehl. Der zurückgegebene Fehler lautet: "HTTP 500 Cannot to log in vCenter 'vcsa.amer.lan': ServerFehlercode: Die Anmeldung kann aufgrund eines falschen Nutzernamens oder Kennworts nicht abgeschlossen werden." ...

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Symptoms

Die Registrierung eines NetWorker VMware Protection (NVP) vProxy schlägt fehl.
Der folgende Fehler wird im Abschnitt Protokoll der Registerkarte Monitoring der NetWorker Management Console (NMC) protokolliert:

VM proxy Warning: Unable to register NSR VMware proxy 'VPROXY_NAME': Received an HTTP code: 500, libcurl message: "", vProxy message: "Error received from vProxy ="500: Unable to log in to vCenter 'VCENTER_NAME': ServerFaultCode: Cannot complete login due to an incorrect user name or password.".

Das gerenderte daemon.raw des NetWorker-Servers meldet dieselben Fehler:

Linux: /nsr/logs/daemon.raw
Windows: C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw

Beispiel:

71193 02/05/2025 10:50:45 AM  nsrd NSR info VM proxy Info: Initiating registration of NSR VMware proxy 'nsr-vproxy01.amer.lan'
71193 02/05/2025 10:50:50 AM  nsrd NSR info VM proxy Warning: Unable to register NSR VMware proxy 'nsr-vproxy01.amer.lan': Received an HTTP code: 500, vProxy ="500: Unable to log in to vCenter 'vcsa.amer.lan': ServerFaultCode: Cannot complete login due to an incorrect user name or password.".

Die NMC VMware View-Aktualisierung funktioniert. Damit wird überprüft, ob der NetWorker-Server über die korrekten vCenter-Zugangsdaten verfügt.
 

HINWEIS: Wenn die VMware View-Aktualisierung den vCenter-Bestand nicht laden kann. Stellen Sie sicher, dass die vCenter-Zugangsdaten korrekt sind. Anweisungen zur Fehlerbehebung finden Sie im Abschnitt Zusätzliche Informationen .

Cause

Der vProxy löst den vCenter Server nicht korrekt auf.

Beispielszenario.

Die vProxy-Appliance hat eine falsche IP-Adresse in der Datei /etc/hosts. Der vProxy kann diese IP-Adresse anpingen. Die IP-Adresse gehört zu einem anderen VMware vCenter, sodass Verbindungen zu Port 443 ebenfalls erfolgreich sind. Es ist jedoch nicht das richtige vCenter, sodass die Authentifizierung fehlschlägt:
nsr-vproxy01:~ # ping -c 4 vcsa.amer.lan
PING vcsa.amer.lan (192.168.9.114) 56(84) bytes of data.
64 bytes from vcsa.amer.lan (192.168.9.114): icmp_seq=1 ttl=64 time=0.455 ms
64 bytes from vcsa.amer.lan (192.168.9.114): icmp_seq=2 ttl=64 time=0.399 ms
64 bytes from vcsa.amer.lan (192.168.9.114): icmp_seq=3 ttl=64 time=0.698 ms
64 bytes from vcsa.amer.lan (192.168.9.114): icmp_seq=4 ttl=64 time=0.361 ms

--- vcsa.amer.lan ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3049ms
rtt min/avg/max/mdev = 0.361/0.478/0.698/0.131 ms
nsr-vproxy01:~ #
nsr-vproxy01:~ # curl -v vcsa.amer.lan:443
*   Trying 192.168.9.114:443...
* Connected to vcsa.amer.lan (192.168.9.114) port 443 (#0)
> GET / HTTP/1.1
> Host: vcsa.amer.lan:443
> User-Agent: curl/8.0.1
> Accept: */*
>
* Empty reply from server
* Closing connection 0
curl: (52) Empty reply from server
Auf dem NetWorker-Server können wir sehen, dass vCenter in eine andere IP-Adresse aufgelöst wird:
[root@nsr ~]# nslookup vcsa.amer.lan
Server:         192.168.9.100
Address:        192.168.9.100#53

Name:   vcsa.amer.lan
Address: 192.168.9.111
HINWEIS: Dieses Szenario ist ein Beispiel. Die Ursache des Problems besteht darin, dass der vProxy den vCenter in eine falsche IP-Adresse auflöst. Je nach Standort und Szenario können andere Symptome beobachtet werden.

Resolution

Dies ist ein Namensauflösungsproblem.

NetWorker: Best Practices für das Troubleshooting von Namensauflösungen
 

  • Wenn die vCenter-IP-Adresse in der Datei /etc/hosts des vProxy festgelegt ist, stellen Sie sicher, dass es sich um die richtige IP-Adresse für vCenter handelt. Stellen Sie außerdem sicher, dass die Datei /etc/hosts nicht mehrere Einträge für den vCenter-Hostnamen oder die IP-Adresse enthält.
  • Wenn die vCenter-IP-Adresse nicht in der Datei /etc/hosts des vProxy festgelegt ist, stellen Sie sicher, dass sie auf dem richtigen DNS-Server aufgelöst wird. Die DNS-Serveradressen werden in der Datei /etc/resolv.conf des vProxy definiert. 
IP_ADDRESS          VCENTER_FQDN         VCENTER_SHORTNAME_ALIAS


Sobald der vProxy in die richtige vCenter-IP-Adresse aufgelöst wird, ist der Registrierungsprozess erfolgreich:

Erfolgreiche vProxy-Registrierung

Additional Information

Wenn die NMC VMware View-Aktualisierung fehlschlägt, gibt es möglicherweise ein Problem bei der Behebung oder Authentifizierung beim vCenter vom NetWorker-Server aus.

1. Stellen Sie sicher, dass der NetWorker-Server den vCenter-Hostnamen in die richtige IP-Adresse auflöst. Überprüfen Sie die Hostdatei des NetWorker-Servers auf widersprüchliche IP-Adressen für den vCenter Server.

Linux: /etc/hosts
Windows: C:\Windows\System32\drivers\etc\hosts
2. Überprüfen Sie, ob Sie sich bei der vCenters vSphere-Weboberfläche mit denselben Anmeldeinformationen anmelden können, die zum Hinzufügen von vCenter zu NetWorker verwendet wurden.
Ein. Klicken Sie in NMC Protection –>VMware View mit der rechten Maustaste auf vCenter und wählen Sie Modify vCenter aus.
vCenter-Zugangsdaten
B. Wenn Sie sich mit demselben Konto bei vSphere anmelden können, aktualisieren Sie das Kennwort in NetWorker, um sicherzustellen, dass es korrekt ist.
C. Wenn Sie sich nicht bei vSphere anmelden können, wenden Sie sich an Ihren VMware-Administrator, um zu überprüfen, ob das Konto korrekt und nicht gesperrt ist und ob das Kennwort korrekt ist.
3. Nachdem VMware View erfolgreich aktualisiert wurde, überwachen Sie die vProxy-Registrierung, um festzustellen, ob sie abgeschlossen wurde.

Das ProxyHC-Dienstprogramm kann auch verwendet werden, um vCenter-Konnektivität und -Berechtigungen zu validieren, siehe: NVP-vProxy: Verwendung des Integritätsprüfungstools ProxyHC auf vProxy-Appliance

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000281396
Article Type: Solution
Last Modified: 05 Feb 2025
Version:  2
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