NVP vProxy : Échec de l’enregistrement : « Impossible de se connecter à vCenter. Nom d’utilisateur ou mot de passe incorrect »
Summary: L’enregistrement d’un vProxy NetWorker VMware Protection (NVP) échoue. L’erreur renvoyée est « HTTP 500 Impossible de se connecter à vCenter 'vcsa.amer.lan' » : ServerFaultCode : Impossible de terminer la connexion en raison d’un nom d’utilisateur ou mot de passe incorrect." » ...
Symptoms
L’enregistrement d’un vProxy NetWorker VMware Protection (NVP) échoue.
L’erreur suivante est consignée dans la section Log de l’onglet Monitoring de NetWorker Management Console (NMC) :
VM proxy Warning: Unable to register NSR VMware proxy 'VPROXY_NAME': Received an HTTP code: 500, libcurl message: "", vProxy message: "Error received from vProxy ="500: Unable to log in to vCenter 'VCENTER_NAME': ServerFaultCode: Cannot complete login due to an incorrect user name or password.".
Le daemon.raw rendu du serveur NetWorker signale les mêmes erreurs :
Windows : C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw
Exemple :
71193 02/05/2025 10:50:45 AM nsrd NSR info VM proxy Info: Initiating registration of NSR VMware proxy 'nsr-vproxy01.amer.lan' 71193 02/05/2025 10:50:50 AM nsrd NSR info VM proxy Warning: Unable to register NSR VMware proxy 'nsr-vproxy01.amer.lan': Received an HTTP code: 500, vProxy ="500: Unable to log in to vCenter 'vcsa.amer.lan': ServerFaultCode: Cannot complete login due to an incorrect user name or password.".
L’actualisation de la vue VMware NMC fonctionne. Cela permet de vérifier que le NetWorker Server dispose des informations d’identification vCenter appropriées.
Cause
Exemple de scénario.
L’appliance vProxy possède une adresse IP incorrecte dans son fichier /etc/hosts. Le vProxy peut envoyer une commande ping à cette adresse IP. L’adresse IP est celle d’un autre VMware vCenter, de sorte que les connexions au port 443 réussissent également. Toutefois, il ne s’agit pas du bon vCenter et l’authentification échoue :
nsr-vproxy01:~ # ping -c 4 vcsa.amer.lan PING vcsa.amer.lan (192.168.9.114) 56(84) bytes of data. 64 bytes from vcsa.amer.lan (192.168.9.114): icmp_seq=1 ttl=64 time=0.455 ms 64 bytes from vcsa.amer.lan (192.168.9.114): icmp_seq=2 ttl=64 time=0.399 ms 64 bytes from vcsa.amer.lan (192.168.9.114): icmp_seq=3 ttl=64 time=0.698 ms 64 bytes from vcsa.amer.lan (192.168.9.114): icmp_seq=4 ttl=64 time=0.361 ms --- vcsa.amer.lan ping statistics --- 4 packets transmitted, 4 received, 0% packet loss, time 3049ms rtt min/avg/max/mdev = 0.361/0.478/0.698/0.131 ms nsr-vproxy01:~ # nsr-vproxy01:~ # curl -v vcsa.amer.lan:443 * Trying 192.168.9.114:443... * Connected to vcsa.amer.lan (192.168.9.114) port 443 (#0) > GET / HTTP/1.1 > Host: vcsa.amer.lan:443 > User-Agent: curl/8.0.1 > Accept: */* > * Empty reply from server * Closing connection 0 curl: (52) Empty reply from serverNous pouvons voir sur le serveur NetWorker que le vCenter est résolu sur une adresse IP différente :
[root@nsr ~]# nslookup vcsa.amer.lan
Server: 192.168.9.100
Address: 192.168.9.100#53
Name: vcsa.amer.lan
Address: 192.168.9.111
Resolution
Il s’agit d’un problème de résolution de noms.
NetWorker : Pratiques d’excellence en matière de résolution de noms
- Si l’adresse IP de vCenter est définie dans le fichier /etc/hosts du vProxy, assurez-vous qu’il s’agit de l’adresse IP correcte pour le vCenter. En outre, assurez-vous que le fichier /etc/hosts ne contient pas plusieurs entrées pour le nom d’hôte ou l’adresse IP de vCenter.
- Si l’adresse IP de vCenter n’est pas définie dans le fichier /etc/hosts du vProxy, assurez-vous qu’elle est correctement résolue vers le serveur DNS approprié. Les adresses du serveur DNS sont définies dans le fichier /etc/resolv.conf du vProxy.
- Les paramètres du serveur DNS vProxy peuvent être corrigés comme suit : NVP vProxy : Comment modifier manuellement les paramètres de l’interface réseau de l’appliance vProxy
- Vous pouvez également définir l’adresse IP correcte dans le fichier /etc/host du vProxy en respectant le format de fichier hosts :
IP_ADDRESS VCENTER_FQDN VCENTER_SHORTNAME_ALIAS
Une fois que le vProxy se résout sur la bonne adresse IP vCenter, le processus d’enregistrement réussit :
Additional Information
Si l’actualisation de la vue VMware NMC échoue, il peut y avoir un problème de résolution ou d’authentification auprès de vCenter à partir du NetWorker Server.
1. Assurez-vous que le NetWorker Server résout le nom d’hôte vCenter à l’adresse IP correcte. Recherchez d’éventuelles adresses IP conflictuelles dans le fichier hosts de NetWorker Server pour le vCenter Server.
Windows : C :\Windows\System32\drivers\etc\hosts
C. Si vous ne parvenez pas à vous connecter à vSphere, consultez votre administrateur VMware pour vérifier si le compte est correct, non verrouillé et si le mot de passe est correct.
L’utilitaire ProxyHC peut également être utilisé pour valider la connectivité et les autorisations vCenter. Voir : NVP-vProxy : Utilisation de l’outil de bilan de santé ProxyHC sur l’appliance vProxy