La actualización de RCM de PowerFlex 4.x en RG de HCI falla con el siguiente error: No se pudieron instalar los VIB

Summary: La actualización de RCM falla durante la instalación de VMware VIB, ya que los archivos necesarios ya no se encuentran en el paquete de RCM/IC.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

La actualización de RCM falla. La actualización de RCM falla durante process_firmware_update:

Inicie sesión en el pod del implementador delgado y vaya a deployment.log del depoyment_ID/Job_ID
ERROR [2025-01-31T07:52:00.660421] 677128: service_deployment.rb:6081:in `process_firmware_update': Encountered an error during firmware update: RuntimeError: env --unset=RUBYOPT --unset=GEM_HOME --unset=RUBYLIB --unset=GEM_PATH --unset=BUNDLE_BIN_PATH RUBYLIB=/opt/service/lib:/opt/asm-deployer/lib:/opt/puppetlabs/puppet/lib:/opt/dependencies/dell-asm-util/lib PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/puppetlabs/puppet/bin:/opt/puppetlabs/bin puppet asm process_node --debug --trace --filename /opt/Dell/ASM/deployments/Job-2b551cc3-f546-4765-9eee-6416de02b254-0-0/resources/rackserver-cxjswf3.yaml --run_type apply --statedir /opt/Dell/ASM/deployments/Job-2b551cc3-f546-4765-9eee-6416de02b254-0-0/resources --always-override rackserver-cxjswf3 failed; output in /opt/Dell/ASM/deployments/Job-2b551cc3-f546-4765-9eee-6416de02b254-0-0/rackserver-abcdef3.out

ERROR [2025-01-31T07:56:00.831433] 677128: service_deployment.rb:7229:in `finalize_firmware_update': Failed to update the server!
INFO  [2025-01-31T07:56:00.831570] 677128: service_deployment.rb:7234:in `finalize_firmware_update': Firmware update status: Error
ERROR [2025-01-31T07:56:00.875669] 677128: service_deployment.rb:675:in `process': Firmware update failed for Job-2b551cc3-f546-4765-9eee-6416de02b254-0-0
ERROR [2025-01-31T07:56:00.875864] 677128: service_deployment.rb:676:in `process': ["/opt/asm-deployer/lib/asm/service_deployment.rb:7238:in `finalize_firmware_update'", "/opt/asm-deployer/lib/asm/service_deployment.rb:6095:in `process_firmware_update'", "/opt/asm-deployer/lib/asm/service_deployment.rb:526:in `process'", "/opt/asm-deployer/lib/asm.rb:385:in `block in process_deployment'", "org/jruby/RubyArray.java:2025:in `each_slice'", "/opt/asm-deployer/lib/asm.rb:366:in `block in process_deployment'", "/opt/dependencies/dell-asm-util/lib/asm/util.rb:22:in `block in execute_async'"]
INFO  [2025-01-31T07:56:00.876253] 677128: service_deployment.rb:678:in `process': Status: Error

Del .out del host ESXi, la instalación falló durante la instalación de los siguientes componentes:

/opt/Dell/ASM/deployments/<JOB_ID>/rackserver-service_tag.out<>
** /opt/Dell/ASM/deployments/Job-2b551cc3-f546-4765-9eee-6416de02b254-0-0/rackserver-abcdef3.out **
Error: Failed to install VIB for
["https://10.92.113.140:443/httpshare/download/8aaa801394ba0c920194ba1b53b00004/vibs70/INT_bootbank_i40en_2.5.2.0-1OEM.700.1.0.15843807.vib__;!!LpKI!glu2235RWNPqShl_xs0gxErxlqUao3Xy5zb_dK_dKz6ireUNS8hD7XuE_BEHR6rXQHNZg5cpfSE5oolHSF-bVBu-6WY7ee0a$ [10[.]92[.]113[.]140]",
"https://10.92.113.140:443/httpshare/download/8aaa801394ba0c920194ba1b53b00004/vibs70/DEL_bootbank_dcism_5.3.0.0.3289-DEL.700.0.0.15843807.vib__;!!LpKI!glu2235RWNPqShl_xs0gxErxlqUao3Xy5zb_dK_dKz6ireUNS8hD7XuE_BEHR6rXQHNZg5cpfSE5oolHSF-bVBu-6RyLpejW$ [10[.]92[.]113[.]140]",
"https://10.92.113.140:443/httpshare/download/8aaa801394ba0c920194ba1b53b00004/vibs70/VMware_locker_tools-light_12.2.6.22229486-22348808.vib__;!!LpKI!glu2235RWNPqShl_xs0gxErxlqUao3Xy5zb_dK_dKz6ireUNS8hD7XuE_BEHR6rXQHNZg5cpfSE5oolHSF-bVBu-6SW0V3E0$ [10[.]92[.]113[.]140]",
"https://10.92.113.140:443/httpshare/download/8aaa801394ba0c920194ba1b53b00004/vibs70/INT_bootbank_ixgben_1.15.1.0-1OEM.700.1.0.15843807.vib__;!!LpKI!glu2235RWNPqShl_xs0gxErxlqUao3Xy5zb_dK_dKz6ireUNS8hD7XuE_BEHR6rXQHNZg5cpfSE5oolHSF-bVBu-6dkiwDeX$ [10[.]92[.]113[.]140]",
"https://10.92.113.140:443/httpshare/download/8aaa801394ba0c920194ba1b53b00004/vibs70/INT_bootbank_i40en_2.5.2.0-1OEM.700.1.0.15843807.vib__;!!LpKI!glu2235RWNPqShl_xs0gxErxlqUao3Xy5zb_dK_dKz6ireUNS8hD7XuE_BEHR6rXQHNZg5cpfSE5oolHSF-bVBu-6WY7ee0a$ [10[.]92[.]113[.]140]",
"https://10.92.113.140:443/httpshare/download/8aaa801394ba0c920194ba1b53b00004/vibs70/DEL_bootbank_dcism_5.3.0.0.3289-DEL.700.0.0.15843807.vib__;!!LpKI!glu2235RWNPqShl_xs0gxErxlqUao3Xy5zb_dK_dKz6ireUNS8hD7XuE_BEHR6rXQHNZg5cpfSE5oolHSF-bVBu-6RyLpejW$ [10[.]92[.]113[.]140]",
"https://10.92.113.140:443/httpshare/download/8aaa801394ba0c920194ba1b53b00004/vibs70/INT_bootbank_ixgben_1.15.1.0-1OEM.700.1.0.15843807.vib__;!!LpKI!glu2235RWNPqShl_xs0gxErxlqUao3Xy5zb_dK_dKz6ireUNS8hD7XuE_BEHR6rXQHNZg5cpfSE5oolHSF-bVBu-6dkiwDeX$ [10[.]92[.]113[.]140]"]: Error RbVmomi::Fault:VimEsxCLICLIFault: EsxCLI.CLIFault.summary

Error: Fault error message: [" [VibFormatError]", " ('<http.client.HTTPResponse object at 0xe3d7cbf310>', \"Not a valid ar file (magic=b'')\")", "  
filename = https://10.92.113.140:443/httpshare/download/8aaa801394ba0c920194ba1b53b00004/vibs70/VMware_locker_tools-light_12.2.6.22229486-22348808.vib__;!!LpKI!glu2235RWNPqShl_xs0gxErxlqUao3Xy5zb_dK_dKz6ireUNS8hD7XuE_BEHR6rXQHNZg5cpfSE5oolHSF-bVBu-6SW0V3E0$ [10[.]92[.]113[.]140]", " Please refer to the log file for more details."]

Debug: Host Maintenance mode = true

Warning: Host is in maintenance mode. Exiting Maintenance mode...

Error: Failed to install VIBs
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util/errors.rb:157:in `fail'

Cause

El problema proviene del hecho de que el archivo VMware_locker_tools-light_12.2.6.22229486-22348808.VIB tiene 0 bytes en el archivo RCM/IC porque DELL ya no proporciona estos archivos. Sin embargo, están disponibles en el depósito de parches de VMware, pero se omitieron durante el proceso de actualización. 

Resolution

Cualquiera de las siguientes soluciones alternativas puede ayudar.

  1. Carga del archivo VIB mediante la actualización de componente único (SCU):
    1. Extraiga VMware_locker_tools-light_12.2.6.22229486-22348808.VIB del depósito de parches de VMware.
    2. Habilite la actualización de componente único (SCU).
      Inicie sesión en cualquiera de los nodos MVM y ejecute lo siguiente:
      kubectl patch hr asmmanager -p '{"spec":{"values":{"appConfig": {"modify_compliance":"true"}}}}' -n powerflex --type=merge
    3. Vaya a la interfaz de usuario de PFMP → a la versión de cumplimiento → seleccione el paquete de RCM → el paquete de software → seleccione "paquete de software ESXi x.x" y haga clic en Ver → Seleccione "VMware Tools VIB para Windows y Linux invitado" en la lista de componentes y haga clic en Modificar.
      Cargue el archivo VMware_locker_tools-light_12.2.6.22229486-22348808.VIB y, en "Nueva versión del paquete", mencione la siguiente versión: 12.2.6.22229486-22348808. La versión aquí sería la misma que se ve en "Versión del paquete". Haga clic en Continuar:
      NOTA: Verá este componente con una etiqueta "Modificado".

       

    4. Realice la actualización de RCM/IC.
       
  2. Instale manualmente VMware Tools VIB:
    1. Instale manualmente el VIB extraído del paquete ZIP de actualización offline descargado de Broadcom:
      # esxcli software vib install -v /<path_to_the_depot>/VMware_locker_tools-light_12.2.6.22229486-22348808.vib
      Installation Result
         Message: Operation finished successfully.
         Reboot Required: false
         VIBs Installed: VMware_locker_tools-light_12.2.6.22229486-22348808
         VIBs Removed: VMware_locker_tools-light_12.3.5.22544099-22545121
         VIBs Skipped:
    2. Ejecute el inventario del host ESXi anterior en la pestaña "Resource".
    3. Compruebe el cumplimiento. El VIB instalado se marca como compatible y se omite durante el proceso de actualización.
    4. Realice la actualización de RCM/IC.
       
  3. Vuelva a intentar la actualización de RCM.  El segundo intento debe ser exitoso.

Additional Information

Versiones afectadas

PFMP 4.x

Problema corregido en la versión

PFMP 4.6.1 

Affected Products

PowerFlex rack RCM Software
Article Properties
Article Number: 000283204
Article Type: Solution
Last Modified: 02 Jun 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.