L'aggiornamento di PowerFlex 4.x RCM su HCI RG ha esito negativo con errore: Impossibile installare i VIB

Summary: L'aggiornamento di RCM non riesce durante l'installazione di VMware VIB poiché i file richiesti non sono più presenti nel pacchetto RCM/IC.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

L'aggiornamento di RCM non riesce. L'aggiornamento di RCM non riesce durante process_firmware_update:

Accedere al pod thin-deployer e passare alla deployment.log del depoyment_ID/Job_ID
ERROR [2025-01-31T07:52:00.660421] 677128: service_deployment.rb:6081:in `process_firmware_update': Encountered an error during firmware update: RuntimeError: env --unset=RUBYOPT --unset=GEM_HOME --unset=RUBYLIB --unset=GEM_PATH --unset=BUNDLE_BIN_PATH RUBYLIB=/opt/service/lib:/opt/asm-deployer/lib:/opt/puppetlabs/puppet/lib:/opt/dependencies/dell-asm-util/lib PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/puppetlabs/puppet/bin:/opt/puppetlabs/bin puppet asm process_node --debug --trace --filename /opt/Dell/ASM/deployments/Job-2b551cc3-f546-4765-9eee-6416de02b254-0-0/resources/rackserver-cxjswf3.yaml --run_type apply --statedir /opt/Dell/ASM/deployments/Job-2b551cc3-f546-4765-9eee-6416de02b254-0-0/resources --always-override rackserver-cxjswf3 failed; output in /opt/Dell/ASM/deployments/Job-2b551cc3-f546-4765-9eee-6416de02b254-0-0/rackserver-abcdef3.out

ERROR [2025-01-31T07:56:00.831433] 677128: service_deployment.rb:7229:in `finalize_firmware_update': Failed to update the server!
INFO  [2025-01-31T07:56:00.831570] 677128: service_deployment.rb:7234:in `finalize_firmware_update': Firmware update status: Error
ERROR [2025-01-31T07:56:00.875669] 677128: service_deployment.rb:675:in `process': Firmware update failed for Job-2b551cc3-f546-4765-9eee-6416de02b254-0-0
ERROR [2025-01-31T07:56:00.875864] 677128: service_deployment.rb:676:in `process': ["/opt/asm-deployer/lib/asm/service_deployment.rb:7238:in `finalize_firmware_update'", "/opt/asm-deployer/lib/asm/service_deployment.rb:6095:in `process_firmware_update'", "/opt/asm-deployer/lib/asm/service_deployment.rb:526:in `process'", "/opt/asm-deployer/lib/asm.rb:385:in `block in process_deployment'", "org/jruby/RubyArray.java:2025:in `each_slice'", "/opt/asm-deployer/lib/asm.rb:366:in `block in process_deployment'", "/opt/dependencies/dell-asm-util/lib/asm/util.rb:22:in `block in execute_async'"]
INFO  [2025-01-31T07:56:00.876253] 677128: service_deployment.rb:678:in `process': Status: Error

Dalla sezione .out dell'host ESXi, l'installazione non è riuscita durante l'installazione dei seguenti componenti:

/opt/Dell/ASM/deployments/<JOB_ID>/rackserver-service_tag.out<>
** /opt/Dell/ASM/deployments/Job-2b551cc3-f546-4765-9eee-6416de02b254-0-0/rackserver-abcdef3.out **
Error: Failed to install VIB for
["https://10.92.113.140:443/httpshare/download/8aaa801394ba0c920194ba1b53b00004/vibs70/INT_bootbank_i40en_2.5.2.0-1OEM.700.1.0.15843807.vib__;!!LpKI!glu2235RWNPqShl_xs0gxErxlqUao3Xy5zb_dK_dKz6ireUNS8hD7XuE_BEHR6rXQHNZg5cpfSE5oolHSF-bVBu-6WY7ee0a$ [10[.]92[.]113[.]140]",
"https://10.92.113.140:443/httpshare/download/8aaa801394ba0c920194ba1b53b00004/vibs70/DEL_bootbank_dcism_5.3.0.0.3289-DEL.700.0.0.15843807.vib__;!!LpKI!glu2235RWNPqShl_xs0gxErxlqUao3Xy5zb_dK_dKz6ireUNS8hD7XuE_BEHR6rXQHNZg5cpfSE5oolHSF-bVBu-6RyLpejW$ [10[.]92[.]113[.]140]",
"https://10.92.113.140:443/httpshare/download/8aaa801394ba0c920194ba1b53b00004/vibs70/VMware_locker_tools-light_12.2.6.22229486-22348808.vib__;!!LpKI!glu2235RWNPqShl_xs0gxErxlqUao3Xy5zb_dK_dKz6ireUNS8hD7XuE_BEHR6rXQHNZg5cpfSE5oolHSF-bVBu-6SW0V3E0$ [10[.]92[.]113[.]140]",
"https://10.92.113.140:443/httpshare/download/8aaa801394ba0c920194ba1b53b00004/vibs70/INT_bootbank_ixgben_1.15.1.0-1OEM.700.1.0.15843807.vib__;!!LpKI!glu2235RWNPqShl_xs0gxErxlqUao3Xy5zb_dK_dKz6ireUNS8hD7XuE_BEHR6rXQHNZg5cpfSE5oolHSF-bVBu-6dkiwDeX$ [10[.]92[.]113[.]140]",
"https://10.92.113.140:443/httpshare/download/8aaa801394ba0c920194ba1b53b00004/vibs70/INT_bootbank_i40en_2.5.2.0-1OEM.700.1.0.15843807.vib__;!!LpKI!glu2235RWNPqShl_xs0gxErxlqUao3Xy5zb_dK_dKz6ireUNS8hD7XuE_BEHR6rXQHNZg5cpfSE5oolHSF-bVBu-6WY7ee0a$ [10[.]92[.]113[.]140]",
"https://10.92.113.140:443/httpshare/download/8aaa801394ba0c920194ba1b53b00004/vibs70/DEL_bootbank_dcism_5.3.0.0.3289-DEL.700.0.0.15843807.vib__;!!LpKI!glu2235RWNPqShl_xs0gxErxlqUao3Xy5zb_dK_dKz6ireUNS8hD7XuE_BEHR6rXQHNZg5cpfSE5oolHSF-bVBu-6RyLpejW$ [10[.]92[.]113[.]140]",
"https://10.92.113.140:443/httpshare/download/8aaa801394ba0c920194ba1b53b00004/vibs70/INT_bootbank_ixgben_1.15.1.0-1OEM.700.1.0.15843807.vib__;!!LpKI!glu2235RWNPqShl_xs0gxErxlqUao3Xy5zb_dK_dKz6ireUNS8hD7XuE_BEHR6rXQHNZg5cpfSE5oolHSF-bVBu-6dkiwDeX$ [10[.]92[.]113[.]140]"]: Error RbVmomi::Fault:VimEsxCLICLIFault: EsxCLI.CLIFault.summary

Error: Fault error message: [" [VibFormatError]", " ('<http.client.HTTPResponse object at 0xe3d7cbf310>', \"Not a valid ar file (magic=b'')\")", "  
filename = https://10.92.113.140:443/httpshare/download/8aaa801394ba0c920194ba1b53b00004/vibs70/VMware_locker_tools-light_12.2.6.22229486-22348808.vib__;!!LpKI!glu2235RWNPqShl_xs0gxErxlqUao3Xy5zb_dK_dKz6ireUNS8hD7XuE_BEHR6rXQHNZg5cpfSE5oolHSF-bVBu-6SW0V3E0$ [10[.]92[.]113[.]140]", " Please refer to the log file for more details."]

Debug: Host Maintenance mode = true

Warning: Host is in maintenance mode. Exiting Maintenance mode...

Error: Failed to install VIBs
/opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util/errors.rb:157:in `fail'

Cause

Il problema deriva dal fatto che il file VMware_locker_tools-light_12.2.6.22229486-22348808.VIB contiene 0 byte nel file RCM/IC perché DELL non fornisce più questi file. Tuttavia, sono disponibili nel deposito di patch VMware, ma sono stati ignorati durante il processo di aggiornamento. 

Resolution

Una qualsiasi delle seguenti soluzioni alternative può essere d'aiuto.

  1. Caricamento del file VIB utilizzando la tecnologia Single Component Upgrade (SCU):
    1. Estrarre VMware_locker_tools-light_12.2.6.22229486-22348808.VIB dal deposito delle patch VMware.
    2. Abilitare l'aggiornamento di un singolo componente (SCU, Single Component Upgrade).
      Accedere a uno dei nodi MVM ed eseguire le seguenti operazioni:
      kubectl patch hr asmmanager -p '{"spec":{"values":{"appConfig": {"modify_compliance":"true"}}}}' -n powerflex --type=merge
    3. Accedere a PFMP UI → Compliance Version → selezionare il pacchetto RCM → il pacchetto software → selezionare 'ESXi x.x Software Bundle' e cliccare su View → selezionare 'VMware Tools VIB for Windows and Linux guest' dall'elenco dei componenti, quindi cliccare su Modify.
      Caricare il file VMware_locker_tools-light_12.2.6.22229486-22348808.VIB e in "Nuova versione pacchetto" indicare la seguente versione 12.2.6.22229486-22348808. La versione qui sarebbe la stessa che vedi in "Versione pacchetto". Cliccare su Proceed:
      NOTA: Questo componente viene visualizzato con il tag "Modificato".

       

    4. Eseguire l'upgrade di RCM/IC.
       
  2. Installare manualmente VMware Tools VIB:
    1. Installare manualmente il VIB estratto dal pacchetto ZIP di aggiornamento offline scaricato da Broadcom:
      # esxcli software vib install -v /<path_to_the_depot>/VMware_locker_tools-light_12.2.6.22229486-22348808.vib
      Installation Result
         Message: Operation finished successfully.
         Reboot Required: false
         VIBs Installed: VMware_locker_tools-light_12.2.6.22229486-22348808
         VIBs Removed: VMware_locker_tools-light_12.3.5.22544099-22545121
         VIBs Skipped:
    2. Eseguire l'inventario per l'host ESXi di cui sopra dalla scheda "Resource".
    3. Verificare la conformità. Il VIB installato viene contrassegnato come conforme e ignorato durante il processo di aggiornamento.
    4. Eseguire l'upgrade di RCM/IC.
       
  3. Riprovare l'aggiornamento di RCM.  Il secondo tentativo dovrebbe avere esito positivo.

Additional Information

Versioni interessate

PFMP 4.x

Risolto nella versione

PFMP 4.6.1 

Affected Products

PowerFlex rack RCM Software
Article Properties
Article Number: 000283204
Article Type: Solution
Last Modified: 02 Jun 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.