PowerProtect : La page de configuration de la sauvegarde de reprise après sinistre affiche l’erreur repositoryHost

Summary: Message d’erreur « 400 : Object has missing required properties (['repositoryHost'])" s’affiche lors de la tentative d’activation des sauvegardes de reprise après sinistre.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

La page de configuration « Disaster Recovery » affiche un message d’erreur similaire à ce qui suit :

Message d’erreur de reprise après sinistre

 

Sur les serveurs PowerProtect Data Manager (PPDM) dans serverdr.log fichier, les messages d’erreur suivants sont signalés :

YYYY-MM-DDTHH:MM:SS.msZ ERROR [] [https-jsse-nio-XXXX-exec-8] [][][][TRACE_ID:xxxxxxxxxxxxxxxxxx][] [c.a.o.v.s.DefaultValidationReportHandler.logApiValidation(88)] -  OpenAPI location=REQUEST key=PUT#/api/v2/server-disaster-recovery-configurations/cd7fcff2-fd68-475f-97ea-0d58aa6417cd levels=ERROR messages=Validation failed.
[ERROR][REQUEST][PUT /api/v2/server-disaster-recovery-configurations/cd7fcff2-fd68-475f-97ea-0d58aa6417cd @body] Object has missing required properties (["repositoryHost"]) 
YYYY-MM-DDTHH:MM:SS.msZ ERROR [] [https-jsse-nio-XXXX-exec-8] [][][][TRACE_ID:xxxxxxxxxxxxxxxxxx][] [c.d.p.r.v.c.OpenApiValidationExceptionHandlingConfiguration$OpenApiValidatorExceptionHandler.handleOpenApiException(35)] -  HandleOpenApiException Trace - Object has missing required properties (['repositoryHost']). 

 

Cause

Lorsque PowerProtect Data Manager a été installé et que Data Domain a été ajouté en tant que stockage, "Auto Enabling Server Disaster Recovery Backups" La tâche a échoué en raison d’un problème d’environnement. Il en est résulté une «serverdr" pour avoir dans son cache les enregistrements qui ont entraîné les messages d’erreur mentionnés ci-dessus.

Resolution

Pour résoudre ce problème, procédez comme suit :

  1. Connectez l’hôte PowerProtect Data Manager à l’aide du client SSH et connectez-vous à l’aide du compte administrateur local.
  2. Redémarrez le service serverdr :
    serverdr restart

     
  3. Patientez 5 minutes, puis réessayez d’activer les sauvegardes de reprise après sinistre. 

Affected Products

PowerProtect Data Manager Appliance, PowerProtect Data Manager, PowerProtect Data Manager Essentials, PowerProtect Data Manager Software
Article Properties
Article Number: 000289914
Article Type: Solution
Last Modified: 29 Aug 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.