PowerProtect: La pagina di configurazione del backup di Disaster Recovery visualizza l'errore repositoryHost

Summary: Messaggio di errore "400: L'oggetto presenta proprietà mancanti richieste (['repositoryHost'])" viene visualizzato durante il tentativo di abilitare i backup di Disaster Recovery.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

La pagina di configurazione "Disaster Recovery" genera un messaggio di errore simile al seguente:

Messaggio di errore di Disaster Recovery

 

Sui server PowerProtect Data Manager (PPDM) all'interno serverdr.log file, vengono segnalati i seguenti messaggi di errore:

YYYY-MM-DDTHH:MM:SS.msZ ERROR [] [https-jsse-nio-XXXX-exec-8] [][][][TRACE_ID:xxxxxxxxxxxxxxxxxx][] [c.a.o.v.s.DefaultValidationReportHandler.logApiValidation(88)] -  OpenAPI location=REQUEST key=PUT#/api/v2/server-disaster-recovery-configurations/cd7fcff2-fd68-475f-97ea-0d58aa6417cd levels=ERROR messages=Validation failed.
[ERROR][REQUEST][PUT /api/v2/server-disaster-recovery-configurations/cd7fcff2-fd68-475f-97ea-0d58aa6417cd @body] Object has missing required properties (["repositoryHost"]) 
YYYY-MM-DDTHH:MM:SS.msZ ERROR [] [https-jsse-nio-XXXX-exec-8] [][][][TRACE_ID:xxxxxxxxxxxxxxxxxx][] [c.d.p.r.v.c.OpenApiValidationExceptionHandlingConfiguration$OpenApiValidatorExceptionHandler.handleOpenApiException(35)] -  HandleOpenApiException Trace - Object has missing required properties (['repositoryHost']). 

 

Cause

Quando è stato installato PowerProtect Data Manager e Data Domain è stato aggiunto come storage, "Auto Enabling Server Disaster Recovery Backups" Processo non riuscito a causa di un problema ambientale. Ciò ha portato a "serverdr" di avere record nella sua cache che hanno comportato i messaggi di errore sopra menzionati.

Resolution

Per risolvere questo problema, è possibile utilizzare la seguente procedura:

  1. Connettere l'host PowerProtect Data Manager utilizzando il client SSH ed effettuare l'accesso utilizzando l'account amministratore locale.
  2. Riavviare il servizio serverdr:
    serverdr restart

     
  3. Attendere 5 minuti e provare ad abilitare nuovamente i backup di Disaster Recovery. 

Affected Products

PowerProtect Data Manager Appliance, PowerProtect Data Manager, PowerProtect Data Manager Essentials, PowerProtect Data Manager Software
Article Properties
Article Number: 000289914
Article Type: Solution
Last Modified: 29 Aug 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.