Avamar: SQL incremental backups getting promoted to full randomly due to LSN mismatch

Summary: SQL incremental backups were getting randomly promoted to full backups despite a recent successful full backup being present.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SQL incremental backups were getting randomly promoted to full backups on a busy SQL server with a lot of transactions. The log gap detection mechanism within Avamar SQL Plugin was triggering incorrectly, even though the Log Sequence Number (LSN) continuity was not broken. 

 

Randomly Avamar SQL Incremental Backups would fail with:

2025-02-05 07:01:16 avsql Info <15765>: A log gap was identified or a full backup was not found.
2025/02/05-07:01:16.98499 [avsql_assist]  ===> sqlconnect::~sqlconnect
2025/02/05-07:01:16.98499 [avsql_assist]  <=== sqlconnect::~sqlconnect
2025/02/05-07:01:16.98499 [avsql_assist]  <=== avsql_assist::snapup_check_timestamps
2025-02-05 07:01:16 avsql Warning <7420>: Forcing FULL backup for database 'sql1\GRS/GRSBLOBS' due to the following reason: A log gap was identified or a full backup was not found.

Cause

A fix was generated to address this issue. This issue shows when the Avamar SQL plug-in algorithm retrieving the last LSN from the SQL server and would no always get the most up-to-date LSN. This behavior caused unexpected promotions to full backups. 

Resolution

Fixes for this issue can be found on the Dell page Avamar Drivers and Download 

  1. Avamar SQL plug-in version 19.10.100.166
    1. Hotfix number 338887 
  2. Avamar SQL plug-in version 19.12.100.186
    1. Hotfix number 338888  

For Hotfixes Download instructions, see:

 Avamar: How to find and download a product hotfix, patch, install or upgrade package from the Dell Support website 

These hotfixes use a new SQL Plugin flag which must be added to the avsql.cmd file or in the Dataset.

  1. To use this new flag in Avamar, follow these steps:
    1. Locate the avsql.cmd file: This file is typically found in the Avamar client installation directory.
    2. Edit the avsql.cmd file: Open the file in a text editor with administrative privileges.
    3. Add the flag below:
    4. Save and close the file 
--latest-lsn-from-msdb=True

When this flag is enabled (True), it ensures that the correct LSN number is retrieved from the SQL server for "log gap" validation.

The above flag can also be added to the dataset.

  1. For UI see Avamar: How to supply specialized flags to Avamar backups
  2. For AUI
    1. Go to the AUI
      1. Locate Backup Policy.
      2. Select a policy
      3. Click Edit.
    2. Go to the Dataset page.
      1. In the Edit Dataset section, enable the toggle labeled "Turn on this toggle to edit dataset"
      2. ​​​​​​​​​​​​​​In the Plugins section:
        1. Select a plug-in.
        2. Turn on the Show Free Form toggle.
    3. Add the required flag using key-value pairs. For example, to enable period lock, use:
      1. Key: [avtar]"Flag"
      2. Value: true
    4. Click Submit to save the dataset changes.

 

Affected Products

Avamar Plug-in for SQL

Products

Avamar
Article Properties
Article Number: 000291727
Article Type: Solution
Last Modified: 05 Sep 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.