Får feilmelding når du prøver å koble til nsrjb på noden for ekstern lagring
Summary: Feilmeldingen nedenfor når du prøver å koble til nsrjb på noden for ekstern lagring. nsrjb: Bruker xxx på "Remote_Storagenode_hostname" har ikke "Operate Devices and Jukeboxes"-privilegiet på "Networker_Server_hostname" Tilbakestill og beholdning gir også den samme feilen. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Når du kjører nsrjb -kommandoen på en ekstern NetWorker-lagringsnode, vises følgende feilmelding:
C:\> nsrjb ####:nsrjb: Failed to connect to the NSR service on NWserver_HostName: Program not registered If on a storage node, enter the NSR server hostname? [NWserver_HostName]: using NWserver_Hostname as the NSR server ####:nsrjb: User 'UserName' on 'StorageNode_Hostname' does not have 'Operate Devices and Jukeboxes' privileges on 'NWserver_HostName'.
Cause
Brukerkontoen som utstedte nsrjb på den eksterne lagringsnoden har ikke rettighet til å utføre enhets- og autochanger-operasjoner.
Resolution
Kjør kommandoen nedenfor fra en oppdatert ledetekst på NetWorker-serveren for å legge til rettighetene til brukeren på lagringsnodeverten.
nsraddadmin UserName@StorageNode_Hostname
MERK: Erstatte
UserName og StorageNode_Hostname med de tilsvarende verdiene fra nsrjb feil.
Du kan også følge trinnene nedenfor fra NetWorker Management Console (NMC) for å legge til rettighetene til brukeren på verten.
1. I NMC klikker du på kategorien Server .
2. I Server-vinduet velger du Brukergrupper.
3. Høyreklikk på Programadministratorer, og velg Egenskaper.
4. I vinduet Programadministratorer for brukergruppeegenskaper, under Brukere, legger du til:
user=UserName,host=StorageNode_Hostname
Affected Products
NetWorkerProducts
NetWorker FamilyArticle Properties
Article Number: 000293578
Article Type: Solution
Last Modified: 16 Apr 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.