Получение сообщения об ошибке при попытке подключения nsrjb на удаленном узле хранения

Summary: При попытке подключения nsrjb на удаленном узле хранения отображается указанная ниже ошибка. NSRJB: Пользователь xxx в "Remote_Storagenode_hostname" не имеет привилегии "Управление устройствами и музыкальными автоматами" в "Networker_Server_hostname" Сброс и инвентаризация также выдают ту же ошибку. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

При запуске команды nsrjb на удаленном узле хранения NetWorker отображается следующее сообщение об ошибке:

C:\> nsrjb
####:nsrjb: Failed to connect to the NSR service on NWserver_HostName: Program not registered

If on a storage node, enter the NSR server hostname? [NWserver_HostName]:
using NWserver_Hostname as the NSR server

####:nsrjb: User 'UserName' on 'StorageNode_Hostname' does not have 'Operate Devices and Jukeboxes' privileges on 'NWserver_HostName'.

Cause

Учетная запись пользователя, вызвавшая решение nsrjb на узле удаленного хранения не имеет прав на выполнение операций с устройством и устройством автоматической смены.

Resolution

В командной строке с повышенными привилегиями на сервере NetWorker выполните следующую команду, чтобы добавить права пользователю на хосте узла хранения.

nsraddadmin UserName@StorageNode_Hostname
ПРИМЕЧАНИЕ. Заменять UserName и StorageNode_Hostname с соответствующими значениями из nsrjb .

Или выполните следующие действия в консоли управления NetWorker Management Console (NMC), чтобы добавить права пользователю на хосте.

1. В NMC перейдите на вкладку Server .
2. В окне Сервер выберите Группы пользователей.
3. Нажмите правой кнопкой мыши на пункт Администраторы приложений и выберите Свойства.
4. В окне User Group Properties Application Administrators в разделе Users добавьте:

user=UserName,host=StorageNode_Hostname

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000293578
Article Type: Solution
Last Modified: 16 Apr 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.