Får fel vid försök att ansluta nsrjb på fjärrlagringsnoden

Summary: Får nedanstående felmeddelande när du försöker ansluta nsrjb till fjärrlagringsnoden. NSRJB: Användare xxx på "Remote_Storagenode_hostname" har inte behörigheten "Använd enheter och jukeboxar" på "Networker_Server_hostname" Återställning och inventering ger också samma fel. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

När du kör nsrjb på en fjärransluten NetWorker-lagringsnod visas följande felmeddelande:

C:\> nsrjb
####:nsrjb: Failed to connect to the NSR service on NWserver_HostName: Program not registered

If on a storage node, enter the NSR server hostname? [NWserver_HostName]:
using NWserver_Hostname as the NSR server

####:nsrjb: User 'UserName' on 'StorageNode_Hostname' does not have 'Operate Devices and Jukeboxes' privileges on 'NWserver_HostName'.

Cause

Användarkontot som utfärdade nsrjb på fjärrlagringsnoden har inte behörighet att utföra enhets- och autochanger-åtgärder.

Resolution

Från en upphöjd kommandotolk på NetWorker-servern kör du kommandot nedan för att lägga till behörigheterna för användaren på lagringsnodvärden.

nsraddadmin UserName@StorageNode_Hostname
Obs! Ersätta UserName och StorageNode_Hostname med motsvarande värden från nsrjb .

Du kan också följa stegen nedan från NetWorker Management Console (NMC) för att lägga till behörigheterna för användaren på värden.

1. I NMC klickar du på fliken Server .
2. I fönstret Server väljer du Användargrupper.
3. Högerklicka på Programadministratörer och välj Egenskaper.
4. I fönstret Programadministratörer för egenskaper för användargrupp under Användare lägger du till:

user=UserName,host=StorageNode_Hostname

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000293578
Article Type: Solution
Last Modified: 16 Apr 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.