PowerProtect Data Manager: Registration of the application agent is not completing
Summary: Registration of the application agent is not completed. This is because we are not getting a response to one of the registration actions within 30 seconds (the default timeout).
Symptoms
Impacted Configuration and Settings: This could happen with any agent-based registration.
Impact on PowerProtect Data Manager: When the registration does not complete, post-registration actions (population of the agent release information and discoveries) may fail.
Cause
Root cause: The PowerProtect Data Manager allows 30 seconds for a response by default. When the response is not received during this time frame, we do not complete the registration activities for the host.
Symptoms found in the logs: In the /var/log/brs/adm/adm.log, we see entries similar to:
2025-03-24T08:35:28.182Z ERROR [] [adm-registration-exec-7] [][][][TRACE_ID:a315d15244f6a206][] [c.e.d.e.a.s.s.i.AgentServiceImpl.sendRequestToAgentWithProtocol(287)] - Failed to send request to agent on host hostname.hostname.COM: com.emc.dpsg.ecdm.adm.shared.exception.AdmException: Unable to send request to unreachable host hostname using address XXX.XXX.XXX.XXX and port 7000 at com.emc.dpsg.ecdm.adm.shared.service.impl.AgentServiceImpl.sendRequestToAgentWithProtocol(AgentServiceImpl.java:266) at com.emc.dpsg.ecdm.adm.shared.service.impl.AgentServiceImpl.isAgentUp(AgentServiceImpl.java:349) at com.emc.dpsg.ecdm.adm.server.service.impl.BaseAgentRegistrationServiceImpl.isAgentUp(BaseAgentRegistrationServiceImpl.java:599) at com.emc.dpsg.ecdm.adm.server.service.impl.BaseAgentRegistrationServiceImpl.lambda$5(BaseAgentRegistrationServiceImpl.java:573) at java.base/java.util.stream.MatchOps$2MatchSink.accept(MatchOps.java:119) at java.base/java.util.stream.Streams$RangeIntSpliterator.tryAdvance(Streams.java:87) at java.base/java.util.stream.IntPipeline.forEachWithCancel(IntPipeline.java:163) at java.base/java.util.stream.AbstractPipeline.copyIntoWithCancel(AbstractPipeline.java:527) at java.base/java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:513)
Resolution
Affected versions: This has been seen in 19.17 and 19.18 release.
Workaround: Perform the following steps.
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Unregister the agent in the client
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Rename the ssl folder (C:\Program Files\DPSAPPS\AgentService\ssl) to ".old"
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Update the value to 12
connectionRequestToAgent: 12 in /usr/local/brs/lib/adm/config/application.yml in PPDM. under : retry: max: 3 intervalInSeconds: 30 maxForConnectException: 6 intervalForConnectException: 30 connectionRequestToAgent: 12
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Restart the adm service and ensure that there are no jobs running during this time and wait for a few min
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Register the agent in the client
Additional Information
Reference Jira#: PPDMESC-9826