NVP vProxy: FLR and Instant Recovery Fail for Cloud Based vCenter
Summary: The NetWorker VMware Protection (NVP) solution is protecting Virtual Machines (VM) in an Azure, AWS, or Google Cloud environment. File Level Restore (FLR) mount, and Instant Access restore operations fail. ...
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Symptoms
- VMware vCenter is deployed as a cloud-based solution:
- VMware Cloud on Amazon Web Services (AWS).
- Azure VMware Solution (AVS)
- Google Cloud VMware Engine (GCVE)
- NetWorker VMware Protection (NVP) vProxy File Level Restore mount, or Instant Recover operations fail. The errors observed can vary but generally consist of:
- vProxy fails to connect to Network File Service (NFS) on the Data Domain.
- vProxy fails to mount VM disks on the target VM during FLR.
Cause
This is expected behavior.
The following operations are not supported for vCenters deployed on cloud platforms:
- File Level Restore from an image-based backup.
- Instant Access Restore from an image-based backup
- Emergency Restore (image-level restore directly to an ESXi host, bypassing the vCenter).
- Application consistent (SQL MSVMAPPAGENT) backup or restore.
- Backup or restore using Network Block Device (NBD) or NBDSLL transport mode.
- Backup or restore of VMs placed inside a folder in the Software-Defined Datacenter (SDDC).
- vProxy redeployment (
nsrvproxy_mgmt redeploy)
This is as per the NetWorker VMware Integration Guide: https://www.dell.com/support/product-details/product/networker/docs
Resolution
Only image-based or Virtual Machine Disk (VMDK) restore are supported on cloud platforms.
In order to perform FLR of a cloud-based VM, the NetWorker client software must be installed on the VM. Configure a NetWorker client on the NetWorker server for the VM and perform client-based backups. See the NetWorker Administration Guide.
Affected Products
NetWorkerProducts
NetWorker FamilyArticle Properties
Article Number: 000303387
Article Type: Solution
Last Modified: 03 Apr 2025
Version: 1
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