Impossible de lancer le bureau publié après la mise à jour du client ThinOS et Azure Virtual Desktop

Summary: Cet article fournit des informations sur l’impossibilité de lancer un bureau publié sur Azure Virtual Desktop (AVD) après la mise à jour de ThinOS vers la version 2502 avec AVD 3.1 v3.1.3044. ...

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Symptoms

Plates-formes concernées :

  • Wyse 5070
  • Wyse 5470
  • Client léger OptiPlex 3000

Systèmes d’exploitation concernés :

  • Dell ThinOS 9 2502 ou version ultérieure

Un message d’erreur inconnue s’affiche sur l’ordinateur Dell ThinOS lors du lancement d’un bureau publié à partir de ThinOS sur un pool d’hôtes AVD.

Unknown Error

  • Les ordinateurs Windows qui se connectent au même pool d’hôtes AVD fonctionnent correctement.
  • L’authentification unique n’est pas activée sur l’environnement AVD.
  • Si vous saisissez manuellement les informations d’identification après les avoir supprimées du pool d’hôtes, l’ordinateur vous invite à nouveau à les saisir et à autoriser la connexion
  • La vérification des journaux de l’ordinateur ThinOS au moment de l’erreur permet de voir (où Session Desktop est le nom d’affichage du pool d’hôtes sur AVD).
    compat\linux\var\log\wlogd\wlogd.log
    [TIMESTAMP] N/WebUIProc/WebUIModule (0/0) [RDP] connecting to "Session Desktop"
    [TIMESTAMP] D/avd            /AVD             (12414/35331) OnCredentialAuthChallenge SessionHost reason: FreshCredentialsRequiredByServer
    [TIMESTAMP] D/avd            /AVD             (12414/35331) OnDisconnected code:44 msg:Unknown error
    [TIMESTAMP] N/avd            /AVD             (12414/35331) Session Desktop Unknown error
  • Lors de la vérification des logs du pool d’hôtes concernés, l’erreur ci-dessous s’affiche au moment du problème :

Il est possible que l’erreur apparaisse lors de la vérification des journaux sur le pool d’hôtes concerné

Cause

La présence du paramètre GPO Toujours demander le mot de passe lors de la connexion sur les hôtes de session Azure est la cause de ce problème :

Demander toujours le mot de passe lors de la connexion

Lorsque cette règle est définie sur Activé, l’hôte de session refuse les informations d’identification transmises par le courtier de connexion et demande de nouvelles informations d’identification.

Sur un ordinateur Windows, l’écran de connexion s’affiche de nouveau. Sur ThinOS, le client échoue avec le message d’erreur Unknown Error.

Pour confirmer si la stratégie est activée, il est possible de vérifier la clé de registre ci-dessous sur l’hôte de session :

HKLM\SOFTWARE\\Policies\\Microsoft\\Windows NT\\Terminal Services
Value Name: fPromptForPassword
Value Type: REG_DWORD
Value: 1

Clé de registre

Resolution

Dell Technologies a connaissance du problème et travaille à sa solution.

Solution de contournement :

L’utilisation de l’une des options ci-dessous devrait permettre une solution de contournement jusqu’à ce qu’une solution puisse être disponible.

  • Désactiver le paramètre GPO Toujours demander le mot de passe lors de la connexion
  • Rétrogradez le package AVD vers la version Microsoft_AVD_3.0.2442.pkg-V3.0.2442
  • Supprimez les informations d’identification enregistrées du pool d’hôtes sur le client léger

Désactiver le paramètre GPO Toujours demander le mot de passe lors de la connexion

Avertissement : Avant de modifier les paramètres de sécurité de votre domaine, vous devez toujours en discuter avec votre équipe de sécurité.
  1. Ouvrez la gestion des stratégies de groupe sur un contrôleur de domaine ou un ordinateur sur lequel les outils d’administration nécessaires sont installés.
  2. Accédez à l’objet de stratégie de groupe (GPO) approprié que vous souhaitez modifier dans le domaine. Cliquez dessus avec le bouton droit de la souris et sélectionnez Modifier....
    Cliquez dessus avec le bouton droit de la souris et sélectionnez Modifier... 
  3. Le groupe Policy Management Editor s’ouvre. Accédez à Configuration > de l’ordinateur Modèles administratifs Composants>>WindowsServices Bureau> à distance Session Bureau à distance Sécurité de l’hôte>.
  4. Localisez la règle intitulée Toujours demander le mot de passe lors de la connexion.
  5. Cliquez avec le bouton droit de la souris sur la politique et sélectionnez Edit.
  6. Dans la fenêtre Policy Settings, définissez le bouton radio sur Disabled.
  7. Cliquez sur Appliquer , puis sur OK pour enregistrer les modifications.
  8. Fermez l’éditeur de gestion des stratégies de groupe.
  9. Pour appliquer les paramètres au pool d’hôtes, vous pouvez redémarrer les serveurs hôtes de session ou exécuter la commande ci-dessous localement sur chacun des serveurs :
    gpupdate /force

Rétrogradez le package AVD vers la version Microsoft_AVD_3.0.2442.pkg-V3.0.2442

La rétrogradation du package AVD vers la version Microsoft_AVD_3.0.2442.pkg-V3.0.2442 permet aux utilisateurs de se connecter correctement à l’hôte de session.

Pour rétrograder le package, procédez comme suit :
  1. Téléchargez le package à partir du package Microsoft AVD v3.0.2442 pour ThinOS 2411 (9.5.4070).
  2. Suivez les étapes décrites dans le Guide de l’administrateur de Dell ThinOS 9.x 2502 pour télécharger le package sur la console Wyse Management Suite (WMS) et l’attribuer aux appareils concernés à l’aide de la stratégie.

Supprimer les informations d’identification enregistrées du pool d’hôtes sur le client léger

Après avoir supprimé les informations d’identification enregistrées du pool d’hôtes, l’appareil invite à nouveau à saisir le nom d’utilisateur et le mot de passe de connexion, ce qui permet d’établir la connexion à la session AVD.

Pour les supprimer, procédez comme suit :
  1. Sur le client léger, effectuez la première connexion au courtier de connexion AVD
  2. Regroupez la barre d’outils sur le côté et cliquez sur Menu VDI
  3. Dans la liste Host Pool, cliquez sur les icônes de paramètres en regard du nom d’affichage du pool d’hôtes, puis cliquez sur Properties
  4. Les propriétés de la session s’affichent, cliquez sur Connexion et supprimez le contenu des champs Nom d’utilisateur de connexion et Mot de passe.
    Cliquez sur Connexion et supprimez le contenu des champs Nom d’utilisateur de connexion et Mot de passe 
  5. Une fois que vous avez terminé, cliquez sur Enregistrer
  6. Cliquez sur Se connecter pour lancer la session. Vous êtes de nouveau invité à saisir les informations d’identification pour accéder à l’hôte de session.

Additional Information

Consultez le Guide de l’administrateur de Dell ThinOS 9.x 2502 pour en savoir plus sur les éléments suivants :

  • Capture des journaux ThinOS à l’aide de Wyse Management Suite Suivez la section Dépannage de votre client > léger Demander un fichier journal à l’aide de Wyse Management Suite
  • Comment transmettre le package AVD aux appareils concernés : section Mise à niveau du firmware > ThinOS Télécharger les packages > du firmware, du BIOS et des applications ThinOS Télécharger et envoyer les packages de l’application ThinOS 9.x à l’aide des groupes et des configurations sur Wyse Management Suite
  • Comment transmettre le package AVD aux appareils concernés : section Mise à niveau du firmware > ThinOS Télécharger les packages > du firmware, du BIOS et des applications ThinOS Télécharger et envoyer les packages de l’application ThinOS 9.x à l’aide des groupes et des configurations sur Wyse Management Suite

Affected Products

OptiPlex 3000 Thin Client, Wyse 5070 Thin Client, Wyse 5470, Dell ThinOS
Article Properties
Article Number: 000303827
Article Type: Solution
Last Modified: 13 May 2025
Version:  3
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