Nie można uruchomić opublikowanego pulpitu po zaktualizowaniu systemu ThinOS i klienta pulpitu wirtualnego platformy Azure

Summary: Ten artykuł zawiera informacje na temat braku możliwości uruchomienia opublikowanego pulpitu w usłudze Azure Virtual Desktop (AVD) po zaktualizowaniu systemu ThinOS do wersji 2502 przy użyciu wersji AVD 3.1 v3.1.3044. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dotyczy platform:

  • Wyse 5070
  • Wyse 5470
  • Terminal kliencki OptiPlex 3000

Dotyczy systemów operacyjnych:

  • Dell ThinOS 9 2502 lub nowszy

Podczas uruchamiania opublikowanego pulpitu z systemu ThinOS w puli hostów AVD na komputerze Dell ThinOS wyświetlany jest komunikat o nieznanym błędzie .

Unknown Error

  • Komputery z systemem Windows łączące się z tą samą pulą hostów AVD działają prawidłowo.
  • Jednokrotne logowanie nie jest włączone w środowisku AVD.
  • Ręczne wprowadzenie poświadczeń po usunięciu ich z puli hostów powoduje, że komputer ponownie wyświetla monit o podanie poświadczeń i zezwala na połączenie
  • Sprawdzając dzienniki komputera ThinOS w momencie wystąpienia błędu, można zobaczyć (gdzie Session Desktop jest nazwą wyświetlaną puli hostów w AVD).
    compat\linux\var\log\wlogd\wlogd.log
    [TIMESTAMP] N/WebUIProc/WebUIModule (0/0) [RDP] connecting to "Session Desktop"
    [TIMESTAMP] D/avd            /AVD             (12414/35331) OnCredentialAuthChallenge SessionHost reason: FreshCredentialsRequiredByServer
    [TIMESTAMP] D/avd            /AVD             (12414/35331) OnDisconnected code:44 msg:Unknown error
    [TIMESTAMP] N/avd            /AVD             (12414/35331) Session Desktop Unknown error
  • Po sprawdzeniu dzienników puli hostów, których dotyczy problem, można zobaczyć poniższy błąd występujący w momencie wystąpienia problemu:

Po sprawdzeniu dzienników w puli hostów, których dotyczy problem, można zobaczyć błąd

Cause

Obecność ustawienia obiektu zasad grupy Zawsze monituj o hasło po nawiązaniu połączenia na hostach sesji platformy Azure jest przyczyną tego problemu:

Zawsze monituj o hasło przy nawiązaniu połączenia

Gdy ta zasada jest ustawiona na wartość Włączone, host sesji odrzuca poświadczenia przekazywane przez brokera połączeń i prosi o nowe poświadczenia.

Na komputerze z systemem Windows powoduje to ponowne wyświetlenie ekranu logowania, natomiast w systemie ThinOS powoduje awarię klienta z powodu błędu Unknown Error.

Aby potwierdzić, czy zasady są włączone, można sprawdzić poniższy klucz rejestru na hoście sesji:

HKLM\SOFTWARE\\Policies\\Microsoft\\Windows NT\\Terminal Services
Value Name: fPromptForPassword
Value Type: REG_DWORD
Value: 1

Klucz rejestru

Resolution

Firma Dell Technologies zna ten problem i pracuje nad rozwiązaniem.

Obejście problemu:

Wykonanie jednej z poniższych opcji powinno zapewnić obejście problemu do momentu udostępnienia rozwiązania.

  • Wyłączanie ustawienia obiektu zasad grupy Zawsze monituj o hasło po nawiązaniu połączenia
  • Zmień wersję pakietu AVD na Microsoft_AVD_3.0.2442.pkg-V3.0.2442
  • Usuń zapisane poświadczenia z puli hostów na terminalu klienckim

Wyłącz ustawienie obiektu zasad grupy Zawsze monituj o hasło przy połączeniu

Ostrzeżenie: Przed zmianą ustawień zabezpieczeń w domenie należy zawsze omówić to z zespołem ds. zabezpieczeń.
  1. Otwórz Zarządzanie zasadami grupy na kontrolerze domeny lub komputerze z zainstalowanymi niezbędnymi narzędziami administracyjnymi.
  2. Przejdź do odpowiedniego obiektu zasad grupy (GPO), który chcesz zmodyfikować w domenie. Kliknij go prawym przyciskiem myszy i wybierz Edytuj....
    Kliknij go prawym przyciskiem myszy i wybierz Edytuj... 
  3. Zostanie otwarty Edytor zarządzania zasadami grupy. Przejdź do opcji Konfiguracja> komputera Szablony administracyjne Składniki>>systemu WindowsUsługi> pulpitu zdalnego Zabezpieczenia hosta> sesji pulpitu zdalnego.
  4. Odszukaj zasadę o nazwie Zawsze monituj o hasło przy połączeniu.
  5. Kliknij prawym przyciskiem myszy zasadę i wybierz polecenie Edytuj.
  6. W oknie ustawień zasad ustaw przycisk opcji na Wyłączone.
  7. Kliknij przycisk Zastosuj , a następnie OK , aby zapisać zmiany.
  8. Zamknij edytor zarządzania zasadami grupy.
  9. Aby zastosować ustawienia puli hostów, możesz ponownie uruchomić serwery hostów sesji lub uruchomić poniższe polecenie lokalnie na każdym z serwerów:
    gpupdate /force

Zmień wersję pakietu AVD na Microsoft_AVD_3.0.2442.pkg-V3.0.2442

Obniżenie wersji pakietu AVD do Microsoft_AVD_3.0.2442.pkg-V3.0.2442 umożliwia użytkownikom pomyślne połączenie się z hostem sesji.

Aby obniżyć wersję pakietu, wykonaj następujące czynności:
  1. Pobierz pakiet z pakietu Microsoft AVD ThinOS 2411 (9.5.4070) w wersji 3.0.2442
  2. Wykonaj czynności opisane w podręczniku administratora systemu Dell ThinOS 9.x 2502 , aby przesłać pakiet do konsoli pakietu Wyse Management Suite (WMS) i przypisać go do urządzeń, których dotyczy problem, przy użyciu zasad.

Usuń zapisane poświadczenia z puli hostów na terminalu klienckim

Usunięcie zapisanych poświadczeń z puli hostów powoduje ponowne wyświetlenie przez urządzenie monitu o podanie nazwy użytkownika i hasła, co pozwala na pomyślne nawiązanie połączenia z sesją AVD.

Aby je usunąć, wykonaj poniższe kroki:
  1. Na terminalu klienckim wykonaj pierwsze logowanie do brokera połączeń AVD
  2. Połącz pasek narzędzi z boku i kliknij menu VDI
  3. Na liście Pula hostów kliknij ikony ustawień obok nazwy wyświetlanej puli hostów, a następnie kliknij przycisk Właściwości
  4. Po wyświetleniu właściwości sesji kliknij przycisk Logon i usuń zawartość pól Login Username i Password.
    Kliknij przycisk Zaloguj i usuń zawartość pól Nazwa użytkownika i Hasło 
  5. Po zakończeniu kliknij przycisk Zapisz.
  6. Kliknij przycisk Połącz, aby uruchomić sesję. Zostanie ponownie wyświetlony monit o podanie poświadczeń w celu uzyskania dostępu do hosta sesji.

Additional Information

Zapoznaj się z podręcznikiem administratora systemu Dell ThinOS 9.x 2502 , aby dowiedzieć się więcej na temat:

  • Rejestrowanie dzienników systemu ThinOS za pomocą oprogramowania Wyse Management Suite Sekcja Rozwiązywanie problemów z terminalem klienckim > Poproś o plik dziennika za pomocą programu Wyse Management Suite.
  • Przesuwanie pakietu AVD na urządzenia, których dotyczy problem? Aktualizacja oprogramowania wewnętrznego > ThinOS Pobieranie oprogramowania wewnętrznego, systemu BIOS i pakietów > aplikacji ThinOS Przesyłanie i przesuwanie pakietów aplikacji ThinOS 9.x przy użyciu grup i konfiguracji w pakiecie Wyse Management Suite
  • Przesuwanie pakietu AVD na urządzenia, których dotyczy problem? Aktualizacja oprogramowania wewnętrznego > ThinOS Pobieranie oprogramowania wewnętrznego, systemu BIOS i pakietów > aplikacji ThinOS Przesyłanie i przesuwanie pakietów aplikacji ThinOS 9.x przy użyciu grup i konfiguracji w pakiecie Wyse Management Suite

Affected Products

OptiPlex 3000 Thin Client, Wyse 5070 Thin Client, Wyse 5470, Dell ThinOS
Article Properties
Article Number: 000303827
Article Type: Solution
Last Modified: 13 May 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.