Julkaistua työpöytää ei voi käynnistää ThinOS:n ja Azure Virtual Desktop Clientin päivityksen jälkeen

Summary: Tässä artikkelissa on tietoja siitä, että julkaistua työpöytää ei voi käynnistää Azure Virtual Desktopissa (AVD), kun ThinOS on päivitetty versioon 2502 AVD 3.1 v3.1.3044 -versiolla.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Ympäristöt, joita tämä koskee:

  • Wyse 5070
  • Wyse 5470
  • OptiPlex 3000 Thin Client

Käyttöjärjestelmät, joita asia koskee:

  • Dell ThinOS 9 2502 tai uudempi

Dell ThinOS -tietokoneessa näkyy Unknown Error -ilmoitus, kun julkaistu työpöytä käynnistetään ThinOS:stä AVD-isäntävarannossa.

Unknown Error

  • Windows-tietokoneet, jotka muodostavat yhteyden samaan AVD-isäntävarantoon, toimivat oikein.
  • Kertakirjautuminen ei ole käytössä AVD-ympäristössä.
  • Kun tunnistetiedot syötetään manuaalisesti sen jälkeen, kun ne on poistettu isäntävarannosta, tietokone pyytää tunnistetietoja uudelleen ja sallii yhteyden muodostamisen
  • Tarkista ThinOS-tietokoneen lokit virheen hetkellä (jossa Session Desktop on AVD:n isäntävarannon näyttönimi).
    compat\linux\var\log\wlogd\wlogd.log
    [TIMESTAMP] N/WebUIProc/WebUIModule (0/0) [RDP] connecting to "Session Desktop"
    [TIMESTAMP] D/avd            /AVD             (12414/35331) OnCredentialAuthChallenge SessionHost reason: FreshCredentialsRequiredByServer
    [TIMESTAMP] D/avd            /AVD             (12414/35331) OnDisconnected code:44 msg:Unknown error
    [TIMESTAMP] N/avd            /AVD             (12414/35331) Session Desktop Unknown error
  • Tarkistamalla ne isäntäpoolin lokit, joita ongelma koskee, on mahdollista nähdä alla oleva virhe ongelman ilmetessä:

Tarkistamalla kyseisen isäntäpoolin lokit on mahdollista nähdä virhe

Cause

Ongelma johtuu ryhmäkäytäntöobjektin asetuksesta Pyydä aina salasanaa yhteyden muodostamisen yhteydessä Azure-istuntoisännissä:

Kysy aina salasanaa yhteyden muodostamisen yhteydessä

Kun käytännön asetuksena on Käytössä, istunnon isäntä hylkää yhteyden välittäjän välittämät tunnistetiedot ja pyytää uusia tunnistetietoja.

Windows-tietokoneessa tämä kehottaa kirjautumisnäyttöä avautumaan uudelleen, mutta ThinOS-käyttöjärjestelmässä se aiheuttaa asiakkaan epäonnistumisen ja Unknown Error -virheen.

Voit tarkistaa, onko käytäntö käytössä, tarkistamalla alla olevan rekisteriavaimen istunnon isännässä:

HKLM\SOFTWARE\\Policies\\Microsoft\\Windows NT\\Terminal Services
Value Name: fPromptForPassword
Value Type: REG_DWORD
Value: 1

rekisteriavain

Resolution

Dell Technologies on tietoinen ongelmasta ja etsii siihen ratkaisua.

Kiertotapa:

Jonkin alla olevista vaihtoehdoista pitäisi tarjota kiertotapa, kunnes ratkaisu on saatavilla.

  • Poista ryhmäkäytäntöasetus käytöstä: Kysy aina salasanaa yhteyden muodostamisen yhteydessä
  • Varhenna AVD-paketti versioon Microsoft_AVD_3.0.2442.pkg-V3.0.2442
  • Poista tallennetut tunnistetiedot Thin Client -työaseman isäntävarannosta

Poista ryhmäkäytäntöasetus käytöstä: Kysy aina salasanaa yhteyden muodostamisen yhteydessä

Varoitus: Ennen kuin muutat toimialueesi suojausasetusta, keskustele asiasta aina tietoturvatiimisi kanssa.
  1. Avaa ryhmäkäytäntöjen hallinta toimialueen ohjauskoneessa tai tietokoneessa, johon on asennettu tarvittavat valvontatyökalut.
  2. Siirry asianmukaiseen ryhmäkäytäntöobjektiin , jota haluat muokata toimialueella. Napsauta sitä hiiren kakkospainikkeella ja valitse Muokkaa....
    Napsauta sitä hiiren kakkospainikkeella ja valitse Muokkaa... 
  3. Ryhmäkäytäntöjen hallintaeditori avautuu. Siirry kohtaan Tietokoneen määritykset> Hallintamallit>Windowsin osat>Etätyöpöytäpalvelut>Etätyöpöytäistunnon isännän> suojaus.
  4. Etsi käytäntö nimeltä Pyydä aina salasanaa yhteyden muodostamisen yhteydessä.
  5. Napsauta käytäntöä hiiren kakkospainikkeella ja valitse Muokkaa.
  6. Aseta käytäntöasetukset-ikkunassa valintanapin arvoksi Ei käytössä.
  7. Napsauta Käytä ja sitten OK tallentaaksesi muutokset.
  8. Sulje ryhmäkäytäntöjen hallintaeditori.
  9. Voit ottaa isäntävarannon asetukset käyttöön käynnistämällä istunnon isäntäpalvelimet uudelleen tai suorittamalla seuraavan komennon paikallisesti kussakin palvelimessa:
    gpupdate /force

Varhenna AVD-paketti versioon Microsoft_AVD_3.0.2442.pkg-V3.0.2442

Kun AVD-paketti varhennetaan versioon Microsoft_AVD_3.0.2442.pkg-V3.0.2442, käyttäjät voivat muodostaa onnistuneen yhteyden istunnon isäntään.

Voit päivittää paketin alempaan versioon seuraavasti:
  1. Lataa paketti ThinOS 2411:stä (9.5.4070) Microsoft AVD -paketti v3.0.2442
  2. Lataa paketti Wyse Management Suite (WMS) -konsoliin ja määritä se ongelman kohteena oleviin laitteisiin käytännön avulla Dell ThinOS 9.x 2502 -järjestelmänvalvojan oppaan ohjeiden mukaisesti.

Poista tallennetut tunnistetiedot Thin Client -työaseman isäntävarannosta

Kun tallennettu tunnistetieto poistetaan isäntävarannosta, laite pyytää jälleen käyttäjänimeä ja salasanaa, jolloin yhteys AVD-istuntoon voidaan muodostaa.

Voit poistaa ne seuraavasti:
  1. Suorita Thin Client -työasemassa ensimmäinen kirjautuminen AVD Connection Broker -palveluun
  2. Kohdista sivussa oleva työkalurivi ja valitse VDI-valikko
  3. Napsauta isäntäpooliluettelossa isäntäpoolin näyttönimen vieressä olevia asetuskuvakkeita ja valitse sitten Ominaisuudet
  4. Istunnon ominaisuudet tulevat näkyviin, valitse Kirjaudu ja poista kenttien Login Username ja Password sisältö.
    Valitse Kirjaudu sisään ja poista kenttien sisältö Käyttäjätunnus ja Salasana 
  5. Kun olet valmis, klikkaa Tallenna
  6. Käynnistä istunto valitsemalla Yhdistä . Sinulta pyydetään uudelleen, että annat tunnistetiedot istunnon isännän käyttöön.

Additional Information

Katso Dell ThinOS 9.x 2502 -järjestelmänvalvojan oppaasta seuraavat tiedot:

  • ThinOS-lokien tallentaminen Wyse Management Suiten avulla Seuraa -osiota Thin Client -työaseman > vianmääritys Lokitiedoston pyytäminen Wyse Management Suiten avulla
  • AVD-paketin lähettäminen laitteisiin, joita ongelma koskee – osio ThinOS-laiteohjelmiston > päivittäminen Lataa ThinOS-laiteohjelmisto, BIOS ja sovelluspaketit > ThinOS 9.x -sovelluspakettien lataaminen Wyse Management Suiten ryhmien ja kokoonpanojen avulla
  • AVD-paketin lähettäminen laitteisiin, joita ongelma koskee – osio ThinOS-laiteohjelmiston > päivittäminen Lataa ThinOS-laiteohjelmisto, BIOS ja sovelluspaketit > ThinOS 9.x -sovelluspakettien lataaminen Wyse Management Suiten ryhmien ja kokoonpanojen avulla

Affected Products

OptiPlex 3000 Thin Client, Wyse 5070 Thin Client, Wyse 5470, Dell ThinOS
Article Properties
Article Number: 000303827
Article Type: Solution
Last Modified: 13 May 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.