PowerProtect Data Manager: Fehler wegen Nichtübereinstimmung von LDAP-Hostnamen während der Vorabprüfung des Upgrades für 19.19

Summary: Die Vorabprüfung des PowerProtect Data Manager-Updates auf 19.19 schlägt mit dem Fehler fehl, dass der LDAP-Hostname nicht übereinstimmt.

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Symptoms

Die Vorabprüfung des PowerProtect Data Manager-Updates auf 19.19 schlägt mit dem Fehler fehl, dass der LDAP-Hostname nicht übereinstimmt.

Die externe Authentifizierung ist für die Verwendung von Active Directory (AD) konfiguriert.

DNS nslookup des AD-Domänencontrollers (DC) gibt den Hostnamen in Großbuchstaben zurück.

Cause

Der Name des Servers im Zertifikat wird in Kleinbuchstaben aufgeführt, aber der Name des Servers in DNS ist großgeschrieben, was zu einer Nichtübereinstimmung führt.

Resolution

Konfigurieren Sie die AD-Authentifizierung mit dem DC-Hostnamen in Großbuchstaben neu und überprüfen Sie das Zertifikat erneut über die PowerProtect Data Manager-Benutzeroberfläche.
Navigieren Sie in der Benutzeroberfläche von PowerProtect Data Manager zu Administration, Access Control und wählen Sie die Registerkarte Directory Settings aus. Wählen Sie die entsprechenden DC-Einstellungen aus und ändern Sie den Hostnamen wie unten beschrieben. Klicken Sie auf Verify, um das Zertifikat zu aktualisieren.
 Änderung des Hostnamens in der PPDM-Benutzeroberfläche
Wenn der Fehler weiterhin besteht, muss das nicht übereinstimmende Zertifikat möglicherweise mit dem ppcp-Tool entfernt werden. 
Verwenden Sie den Befehl "ppcp", um die Zertifikate wie folgt aufzulisten.
admin@ppdm:~/bin> ./ppcp certs list
===========================================================
PPCP  :  0.46
PPDM  :  19.17.0-18
Date  :  07 Apr 2025 10:54 EDT
===========================================================
                   id                  |        host        | port |               fingerprint                |  state   | type
---------------------------------------+--------------------+------+------------------------------------------+----------+-------
  dW5pdHktdnNhLmFtZXIubGFuOjQ0Mzpob3N0 | hostname1.domain.com |  443 | A913D8598D5952D6E24498A02E6F649CEB27AB6C | ACCEPTED | ROOT
  aXNpbG9uOTQuYW1lci5sYW46ODA4MDpob3N0 | hostname2.domain.com | 8080 | FFD0689DCFF36DA6493925CF1EB8A133C02FD872 | ACCEPTED | ROOT
  cm9vdGNh                             | rootca               |      | AECB37080A9D9D70F4CD36951883781C1E3E32A3 | ACCEPTED | ROOT
  ZGMuYW1lci5sYW46NjM2Omhvc3Q=         | dc.domain.com        |  636 | 027E866901EEBE9F88B5266D6D3F593D0169D364 | ACCEPTED | HOST
  ZGR2ZTAyLmFtZXIubGFuOjMwMDk6aG9zdA== | hostname4.domain.com | 3009 | DA3F9888759B86F45DCC3D51ADDF51CA3C618634 | ACCEPTED | HOST
  ZGR2ZTAxLmFtZXIubGFuOjMwMDk6aG9zdA== | hostname5.domain.com | 3009 | 5EE6C8B2768DC19615E3517B86355D251F91A53B | ACCEPTED | HOST
  dmNzYS5hbWVyLmxhbjo0NDM6aG9zdA==     | hostname6.domain.com |  443 | DA47C69E6E81E9EC6819ABEB8F76CC882813ECD4 | ACCEPTED | HOST

Wählen Sie die ID für den betroffenen DC aus und verwenden Sie den folgenden Befehl, um das Zertifikat zu entfernen. Notieren Sie sich unbedingt den verwendeten Port (636 im obigen Beispiel), falls er später benötigt wird. 
 
admin@ppdm:~/bin> ./ppcp certs delete --certid ZGMuYW1lci5sYW46NjM2Omhvc3Q=

Sobald das Zertifikat entfernt wurde, können die obigen Schritte wiederholt werden, um das Zertifikat in der PowerProtect Data Manager-Benutzeroberfläche neu zu erstellen. Alternativ kann der folgende Befehl "ppcp" verwendet werden. (Der Port sollte auf den im obigen Befehl angegebenen Port festgelegt werden.)
admin@ppdm:~/bin> ./ppcp certs add --host HOSTNAME.domain.com --port 636

Article Properties
Article Number: 000305011
Article Type: Solution
Last Modified: 09 Apr 2025
Version:  1
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