PowerProtect Data Manager : Erreur de non-correspondance du nom d’hôte LDAP lors de la vérification préalable à la mise à niveau de la version 19.19

Summary: La vérification préalable de la mise à jour de PowerProtect Data Manager vers la version 19.19 échoue avec une erreur d’échec de correspondance du nom d’hôte LDAP.

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Symptoms

La vérification préalable de la mise à jour de PowerProtect Data Manager vers la version 19.19 échoue avec une erreur d’échec de correspondance du nom d’hôte LDAP.

L’authentification externe est configurée pour utiliser Active Directory (AD).

DNS nslookup du contrôleur de domaine AD (DC) renvoie le nom d’hôte en majuscules.

Cause

Le nom du serveur dans le certificat est répertorié en minuscules, mais le nom du serveur dans DNS est en majuscules, ce qui entraîne une incompatibilité.

Resolution

Reconfigurez l’authentification AD avec le nom d’hôte DC en majuscules et vérifiez à nouveau le certificat à partir de l’interface utilisateur de PowerProtect Data Manager.
Dans l’interface utilisateur de PowerProtect Data Manager, accédez à Administration, Access Control et sélectionnez Directory Settings. Sélectionnez les paramètres DC concernés et modifiez le nom d’hôte comme indiqué ci-dessous. Cliquez sur Verify pour mettre à jour le certificat.
 Modification du nom d’hôte dans l’interface utilisateur PPDM
Si l’erreur persiste, vous devrez peut-être supprimer le certificat incompatible à l’aide de l’outil « ppcp ». 
Utilisez la commande « ppcp » pour répertorier les certificats comme ci-dessous.
admin@ppdm:~/bin> ./ppcp certs list
===========================================================
PPCP  :  0.46
PPDM  :  19.17.0-18
Date  :  07 Apr 2025 10:54 EDT
===========================================================
                   id                  |        host        | port |               fingerprint                |  state   | type
---------------------------------------+--------------------+------+------------------------------------------+----------+-------
  dW5pdHktdnNhLmFtZXIubGFuOjQ0Mzpob3N0 | hostname1.domain.com |  443 | A913D8598D5952D6E24498A02E6F649CEB27AB6C | ACCEPTED | ROOT
  aXNpbG9uOTQuYW1lci5sYW46ODA4MDpob3N0 | hostname2.domain.com | 8080 | FFD0689DCFF36DA6493925CF1EB8A133C02FD872 | ACCEPTED | ROOT
  cm9vdGNh                             | rootca               |      | AECB37080A9D9D70F4CD36951883781C1E3E32A3 | ACCEPTED | ROOT
  ZGMuYW1lci5sYW46NjM2Omhvc3Q=         | dc.domain.com        |  636 | 027E866901EEBE9F88B5266D6D3F593D0169D364 | ACCEPTED | HOST
  ZGR2ZTAyLmFtZXIubGFuOjMwMDk6aG9zdA== | hostname4.domain.com | 3009 | DA3F9888759B86F45DCC3D51ADDF51CA3C618634 | ACCEPTED | HOST
  ZGR2ZTAxLmFtZXIubGFuOjMwMDk6aG9zdA== | hostname5.domain.com | 3009 | 5EE6C8B2768DC19615E3517B86355D251F91A53B | ACCEPTED | HOST
  dmNzYS5hbWVyLmxhbjo0NDM6aG9zdA==     | hostname6.domain.com |  443 | DA47C69E6E81E9EC6819ABEB8F76CC882813ECD4 | ACCEPTED | HOST

Sélectionnez l’ID du contrôleur de domaine concerné et utilisez la commande ci-dessous pour supprimer le certificat. Assurez-vous de noter le port utilisé (636 dans l’exemple ci-dessus), au cas où il serait nécessaire ultérieurement. 
 
admin@ppdm:~/bin> ./ppcp certs delete --certid ZGMuYW1lci5sYW46NjM2Omhvc3Q=

Une fois le certificat supprimé, vous pouvez répéter les étapes ci-dessus pour recréer le certificat dans l’interface utilisateur de PowerProtect Data Manager. Vous pouvez également utiliser la commande « ppcp » suivante. (Le port doit être défini sur le port indiqué dans la commande ci-dessus.)
admin@ppdm:~/bin> ./ppcp certs add --host HOSTNAME.domain.com --port 636

Article Properties
Article Number: 000305011
Article Type: Solution
Last Modified: 09 Apr 2025
Version:  1
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