PowerProtect Data Manager: Błąd niezgodności nazwy hosta LDAP podczas wstępnej kontroli uaktualnienia 19.19

Summary: Aktualizacja wstępna PowerProtect Data Manager do wersji 19.19 kończy się niepowodzeniem z błędem dopasowania nazwy hosta LDAP.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Aktualizacja wstępna PowerProtect Data Manager do wersji 19.19 kończy się niepowodzeniem z błędem dopasowania nazwy hosta LDAP.

Uwierzytelnianie zewnętrzne jest skonfigurowane do korzystania z usługi Active Directory (AD).

Funkcja nslookup systemu DNS kontrolera domeny usługi AD zwraca nazwę hosta wielkimi literami.

Cause

Nazwa serwera w certyfikacie jest zapisana małymi literami, ale nazwa serwera w systemie DNS jest zapisana wielkimi literami, co powoduje niezgodność.

Resolution

Ponownie skonfiguruj uwierzytelnianie AD z nazwą hosta DC zapisaną wielkimi literami i ponownie zweryfikuj certyfikat w interfejsie użytkownika PowerProtect Data Manager.
W interfejsie użytkownika PowerProtect Data Manager przejdź do sekcji Administracja, Kontrola dostępu i wybierz opcję Ustawienia katalogu. Wybierz ustawienia kontrolera domeny, których dotyczy problem, i zmodyfikuj nazwę hosta w sposób wskazany poniżej. Kliknij Verify, aby zaktualizować certyfikat.
 Zmiana nazwy hosta w interfejsie użytkownika PPDM
Jeśli błąd będzie się powtarzał, może być konieczne usunięcie niezgodnego certyfikatu za pomocą narzędzia "ppcp". 
Użyj polecenia "ppcp", aby wyświetlić listę certyfikatów, jak pokazano poniżej.
admin@ppdm:~/bin> ./ppcp certs list
===========================================================
PPCP  :  0.46
PPDM  :  19.17.0-18
Date  :  07 Apr 2025 10:54 EDT
===========================================================
                   id                  |        host        | port |               fingerprint                |  state   | type
---------------------------------------+--------------------+------+------------------------------------------+----------+-------
  dW5pdHktdnNhLmFtZXIubGFuOjQ0Mzpob3N0 | hostname1.domain.com |  443 | A913D8598D5952D6E24498A02E6F649CEB27AB6C | ACCEPTED | ROOT
  aXNpbG9uOTQuYW1lci5sYW46ODA4MDpob3N0 | hostname2.domain.com | 8080 | FFD0689DCFF36DA6493925CF1EB8A133C02FD872 | ACCEPTED | ROOT
  cm9vdGNh                             | rootca               |      | AECB37080A9D9D70F4CD36951883781C1E3E32A3 | ACCEPTED | ROOT
  ZGMuYW1lci5sYW46NjM2Omhvc3Q=         | dc.domain.com        |  636 | 027E866901EEBE9F88B5266D6D3F593D0169D364 | ACCEPTED | HOST
  ZGR2ZTAyLmFtZXIubGFuOjMwMDk6aG9zdA== | hostname4.domain.com | 3009 | DA3F9888759B86F45DCC3D51ADDF51CA3C618634 | ACCEPTED | HOST
  ZGR2ZTAxLmFtZXIubGFuOjMwMDk6aG9zdA== | hostname5.domain.com | 3009 | 5EE6C8B2768DC19615E3517B86355D251F91A53B | ACCEPTED | HOST
  dmNzYS5hbWVyLmxhbjo0NDM6aG9zdA==     | hostname6.domain.com |  443 | DA47C69E6E81E9EC6819ABEB8F76CC882813ECD4 | ACCEPTED | HOST

Wybierz identyfikator kontrolera domeny, którego dotyczy problem, i użyj poniższego polecenia, aby usunąć certyfikat. Pamiętaj, aby zanotować używany port (636 w powyższym przykładzie), na wypadek, gdyby był potrzebny później. 
 
admin@ppdm:~/bin> ./ppcp certs delete --certid ZGMuYW1lci5sYW46NjM2Omhvc3Q=

Po usunięciu certyfikatu można powtórzyć powyższe czynności, aby odtworzyć certyfikat w interfejsie użytkownika PowerProtect Data Manager. Można też użyć następującego polecenia "ppcp". (Port powinien być ustawiony na port zanotowany w powyższym poleceniu).
admin@ppdm:~/bin> ./ppcp certs add --host HOSTNAME.domain.com --port 636

Article Properties
Article Number: 000305011
Article Type: Solution
Last Modified: 09 Apr 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.