Data Domain:CIFS 和 NTP 时间同步验证和配置

Summary: 本文介绍如何在与 Active Directory (AD) 集成的系统上管理时间同步。它包括验证时间同步配置、检测网络时间协议 (NTP) 与 AD 时间控制之间的潜在冲突的步骤。它还提供了禁用通用 Internet 文件系统 (CIFS) 时间同步和确保正确管理时间的命令。它还包括使用日志和系统状态检查的验证步骤,以确保配置正确。

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Symptoms

  • 意外的系统时间更改
  • 身份验证或 Kerberos 错误
  • 跨域系统的时间偏移
  • 来自 NTP 和 AD 的时间更新冲突
  • 显示频繁时间调整的日志条目 (ADSyncTimeToDC)

Cause

NTP 和 Active Directory 都在尝试控制系统时间,从而导致冲突。当在集成了 AD 的系统上同时启用 CIFS 时间同步和 NTP 时,可能会导致时间偏移、身份验证问题和系统不稳定。

Resolution

请按照以下步骤识别并解决与 Active Directory 集成的系统上的时间同步冲突:

  1. 检查系统是否已加入 Active Directory:
运行以下命令:
cifs troubleshooting domaininfo
查找以下行:
[Authentication provider: lsa-activedirectory-provider]
如果列出了此提供程序,则系统正在使用 Active Directory 进行身份验证,并且可能从中接收时间同步。您可以从 自动支持获取此信息。
  1. 检查 NTP 状态:
运行:
ntp status

Example output:

Status                                     Enabled
Current Clock Time                         Fri Mar 14 11:04:17.535 2025
Clock Last Synchronized                    Fri Mar 14 10:53:04.617 2025
Clock Last Synchronized With Time Server   10.92.32.52
如果在系统加入 AD 时启用了 NTP, 这可能会导致时间同步冲突。
  1. 查看时间同步日志:
运行以下命令以检查 AD 触发的时间更改:
grep ADSync cifs.log

Example output:

Mar  4 02:41:26 aurdd5246 lsass: ALWAYS: [24531/...] [lsass] ADSyncTimeToDC: Attempting to change System Time, from [Tue Mar  4 02:41:26 2025 ] to [Fri May  2 20:19:46 2025 ]
May  2 20:34:46 aurdd5246 lsass: ALWAYS: [24531/...] [lsass] ADSyncTimeToDC: Attempting to change System Time, from [Fri May  2 20:34:46 2025 ] to [Tue Mar  4 02:56:25 2025 ]
这些条目表明 Active Directory 正在尝试控制系统时间,如果同时启用两者,这可能与 NTP 冲突。
  1. 确定解决路径:
  • 如果配置了 AD 且启用了 NTP, 则这是配置错误。
为避免时间冲突,请执行以下作:

禁用 NTP 并允许 Active Directory 管理系统时间。

  • 如果只有一个方法处于活动状态(NTP 或 AD), 则无需执行任何作
系统已正确配置。

Affected Products

Data Domain
Article Properties
Article Number: 000305261
Article Type: Solution
Last Modified: 10 Dec 2025
Version:  3
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