NetWorker: I saveset clonati in Cloud Tier non vengono contrassegnati come Transit dopo l'aggiornamento a NetWorker 19.11

Summary: Questo articolo descrive un difetto rilevato in NetWorker che impedisce di contrassegnare correttamente i saveset appena clonati per la migrazione al cloud quando si utilizzano dispositivi Data Domain Cloud Tier. ...

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Symptoms

  • I saveset sono stati clonati correttamente in dispositivi DD Cloud Tier
  • Dopo l'indagine, i saveset appena clonati non vengono contrassegnati come In Transit nel database dei supporti di NetWorker
  • L'utilizzo del tier attivo può aumentare in modo imprevisto poiché i saveset di volume DD Cloud Tier non vengono migrati nel cloud
  • La clonazione o il ripristino dai saveset su DD Cloud Tier genera errori
  • Il problema riguarda i saveset clonati su Cloud Tier dopo l'aggiornamento a 19.11 da 19.10 che erano stati clonati con RPS disabilitato

Cause

Questo problema è attualmente in fase di revisione da parte di NetWorker Engineering. I saveset clonati in dispositivi DD Cloud Tier sono interessati dalla disabilitazione della clonazione RPS. Questa impostazione è rappresentata nelle proprietà del server NetWorker Management Console:
L'opzione RPS disabled è impostata sul server NetWorker

I saveset in questione non riescono a leggere, ripristinare o clonare perché NetWorker interpreta normalmente il flag di assenza di Transit nel database dei supporti: in particolare, il saveset è già stato migrato e deve essere richiamato dal cloud per qualsiasi operazione di lettura. Tuttavia, a causa del difetto descritto, i dati non sono mai stati migrati, quindi, nonostante la copia del tier attivo sia presente e valida, il tentativo di richiamo non riesce.

Resolution

NOTA: Il difetto è in fase di analisi e questo articolo verrà aggiornato man mano che verranno testate e verificate le correzioni per i saveset interessati. 

Soluzione alternativa:

Assicurarsi che l'opzione Disable RPS Clone sia deselezionata sul server NetWorker; il che significa che la clonazione RPS è abilitata. I saveset clonati con RPS abilitato non sono interessati, vengono contrassegnati correttamente e migrati al cloud. Questa modifica ha effetto immediato per tutti i processi di clonazione avviati dopo la modifica. I saveset interessati non verranno aggiornati retroattivamente con i flag corretti. Utilizzare NetWorker Management Console (NMC) o il server NetWorker nsradmin per controllare e modificare questa impostazione.

 

NetWorker Management Console (NMC)

Da NMC effettuare le seguenti operazioni:

  1. Cliccare sulla scheda Server .
  2. Selezionare la risorsa NetWorker Server dal menu a sinistra.
  3. Cliccare su Server Properties.
  4. Nella scheda General , selezionare l'opzione Disable RPS Cloning . Se l'opzione è selezionata, deselezionarla.

Abilitazione della clonazione RPS 

nsradmin

Per verificare se la clonazione RPS è disabilitata nell'ambiente in uso, immettere il tag nsradmin prompt interattivo sul server NetWorker:

nsradmin

Dal prompt, filtrare la proprietà e visualizzare il valore:

nsradmin> show Disable RPS clone
nsradmin> print type: nsr

NOTA: Il valore Yes indica che è possibile riscontrare il difetto nella datazone. Il valore No è preferibile e dovrebbe essere la configurazione scelta, a meno che non si verifichino problemi con la clonazione e che sia stata disabilitata seguendo le indicazioni del supporto Dell.

Per riabilitare la clonazione RPS, dal prompt interattivo, aggiornare il valore su No:

nsradmin> update Disable RPS Clone: No

Products

NetWorker
Article Properties
Article Number: 000308066
Article Type: Solution
Last Modified: 14 Apr 2025
Version:  1
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