PowerStore:使用 SMB 網域加入狀態時未正確更新 svc_nas_cifssupport

Summary: 使用svc_nas_cifssupport命令列工具加入或取消加入 Active Directory 網域時,PowerStore UI 可能不會反映 SMB 伺服器加入狀態的新狀態。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

無法透過 PowerStore UI 或 PSTCLI 管理 SMB 伺服器 Active Directory 組態。
出現以下錯誤:

 

Cause

雖然 SMB 伺服器的內部狀態已適當更新,但在使用 svc_nas_cifssupport 加入或取消加入網域時,目前的狀態並未正確同步至 PowerStore 管理資料庫。

Resolution

如何識別問題:

嘗試修改加入狀態時,若嘗試使用 PowerStore UI 修改 SMB 伺服器 Active Directory 加入狀態,可能會在嘗試修改加入狀態時傳回衝突錯誤。例如,如果網域是使用 svc_nas_cifssupport 加入,PowerStore UI 可能會顯示其尚未加入,並在嘗試加入時傳回錯誤。此外,我報告的系統出現 AD 連線問題,儘管沒有發生任何影響。
 

# pstcli -d POWERSTORE_MGMT_IP -u admin -service -session
 
cli> nas_server show -query "name = NAS_SERVER_NAME" -select id
 #  |                  id
----+--------------------------------------
  1 | xxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
 
cli> nas_server object_sync -object_type nas_server -id NAS_SERVER_ID_FROM_ABOVE -mode local
Success
 
cli> smb_server show
 #  |                  id                  | computer_name |     domain     | workgroup | is_standalone | is_joined | nas_server.name
----+--------------------------------------+---------------+----------------+-----------+---------------+-----------+-----------------
  1 | yyyyyyyy-yyyy-yyyy-yyyy-xxxxxxxxxxxx| COMPUTER_NAME | AD_DOMAIN.COM  |           | no            | yes       | NAS_SERVER_NAME

 

 

因應措施:

使用 PSTCLI 時,PowerStore 平台目前狀態可正確同步。如需進一步變更,可在 GUI/pstcli 中使用一般方式完成。
 

Affected Products

PowerStore
Article Properties
Article Number: 000322164
Article Type: Solution
Last Modified: 27 May 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.