PowerStore:使用 SMB 域时未正确更新 svc_nas_cifssupport

Summary: 使用 svc_nas_cifssupport 命令行工具加入或退出 Active Directory 域时,PowerStore UI 可能无法反映 SMB 服务器加入状态的新状态。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

无法通过 PowerStore UI 或 PSTCLI 管理 SMB 服务器 Active Directory 配置。
出现以下错误:

 

Cause

虽然 SMB 服务器的内部状态已相应更新,但在使用 svc_nas_cifssupport 加入或退出域时,当前状态未正确同步到 PowerStore 管理数据库。

Resolution

如何确定问题:

尝试修改加入状态时,尝试使用 PowerStore UI 修改 SMB 服务器 Active Directory 加入状态可能会返回冲突错误。例如,如果使用 svc_nas_cifssupport 加入域,则 PowerStore UI 可能会显示它未加入,并在尝试加入时返回错误。此外,我的系统报告的 AD 连接问题,虽然没有发生影响。
 

# pstcli -d POWERSTORE_MGMT_IP -u admin -service -session
 
cli> nas_server show -query "name = NAS_SERVER_NAME" -select id
 #  |                  id
----+--------------------------------------
  1 | xxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
 
cli> nas_server object_sync -object_type nas_server -id NAS_SERVER_ID_FROM_ABOVE -mode local
Success
 
cli> smb_server show
 #  |                  id                  | computer_name |     domain     | workgroup | is_standalone | is_joined | nas_server.name
----+--------------------------------------+---------------+----------------+-----------+---------------+-----------+-----------------
  1 | yyyyyyyy-yyyy-yyyy-yyyy-xxxxxxxxxxxx| COMPUTER_NAME | AD_DOMAIN.COM  |           | no            | yes       | NAS_SERVER_NAME

 

 

解决办法:

使用 PSTCLI 时,可以正确同步 PowerStore 平台当前状态。可以在 GUI/pstcli 中使用正常方式进行进一步的更改。
 

Affected Products

PowerStore
Article Properties
Article Number: 000322164
Article Type: Solution
Last Modified: 27 May 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.