3.x'ten 4.x'e PowerFlex Yükseltmesi, ElasticSearch ile ilgili sorun nedeniyle başarısız bir veritabanı yedeklemesi başarısız oluyor

Summary: Bu makalede, bir yedekleme hatası ve ElasticSearch ile ilgili bir sorun nedeniyle 3.x'ten 4.x'e yükseltme hatasının nasıl çözüleceği açıklanmaktadır.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

3.x ten 4.x e PowerFlex Yükseltmesi içe aktarma prosedürü sırasında başarısız oluyor, eski PowerFlex 3.8.3 ün veritabanı yedeklemesi tetikleniyor ve başarısız oluyor.

 

2025-05-21 15:10:06,299 INFO [backup-1,tid=252] (BackupApplianceCallable.java:216): Executing the script: /opt/Dell/scripts/backup-elasticsearch.py
2025-05-21 15:10:16,779 DEBUG [backup-1,tid=252] (ExecuteSystemCommands.java:103): Last login: Wed May 21 15:10:01 CEST 2025 on cron
2025-05-21 15:10:16,780 ERROR [backup-1,tid=252] (ExecuteSystemCommands.java:127): Non-zero return code running OS command /usr/bin/sudo /opt/Dell/scripts/backup-elasticsearch.py: 3
2025-05-21 15:10:16,781 ERROR [backup-1,tid=252] (ExecuteSystemCommands.java:128): Console output running OS command: Last login: Wed May 21 15:10:01 CEST 2025 on cron
2025-05-21 15:10:16,781 ERROR [backup-1,tid=252] (BackupApplianceCallable.java:225): Error executing the script /opt/Dell/scripts/backup-elasticsearch.py: rc=3
2025-05-21 15:10:16,781 ERROR [backup-1,tid=252] (BackupApplianceCallable.java:246): Unable to backup the database. com.dell.asm.i18n2.exception.AsmCheckedException: The appliance cannot be backed because of an unknown exception.
2025-05-21 15:10:16,785 INFO [backup-1,tid=252] (BackupApplianceCallable.java:73): Executing the script /opt/Dell/scripts/backup-clean.sh

 

ASM Yöneticisi günlüğü
 

Line 16272: 2025-05-21 11:32:50,308 DEBUG [backup-1,tid=245] (ExecuteSystemCommands.java:103): rm: cannot remove ‘/var/es-backup/indices’: Directory not empty
Line 16276: 2025-05-21 11:32:50,315 ERROR [backup-1,tid=245] (ExecuteSystemCommands.java:128): Console output running OS command: rm: cannot remove ‘/var/es-backup/indices’: Directory not emptyCleanup of /var/es-backup failed with RC=1Last login: Wed May 21 11:32:35 CEST 2025
Line 18203: 2025-05-21 12:02:54,161 DEBUG [backup-1,tid=245] (ExecuteSystemCommands.java:103): rm: cannot remove ‘/var/es-backup/indices’: Directory not empty
Line 18207: 2025-05-21 12:02:54,165 ERROR [backup-1,tid=245] (ExecuteSystemCommands.java:128): Console output running OS command: rm: cannot remove ‘/var/es-backup/indices’: Directory not emptyCleanup of /var/es-backup failed with RC=1Last login: Wed May 21 12:02:37 CEST 2025

Cause

ElasticSearch verileriyle ilgili bir sorun  

Resolution

Komutlar, delladmin hesabı kullanılarak PowerFlex Manager CLI üzerinde çalıştırılır.

 

1. adım = elastik arama veritabanında yer açma (maksimum boyut 5G olmalıdır)

   

  • curl 'localhost:9200/_cat/indices?v’

 

Çok sayıda snmp tuzak dizini varsa ve bunu kabul ediyorsanız eski tuzakları silebilirsiniz:

 

  • curl -X DELETE localhost:9200/snmp-traps-YYYY.MM.DD (this deletes a specific date)

 

Veya hepsini aşağıdaki komutla silebilirsiniz:

 

  • curl -X DELETE 'http://localhost:9200/syslog* [localhost]'

 

Adım 2 = elastik arama günlüklerini kaldırın.

  • sudo systemctl status Elasticsearch
    sudo systemctl stop Elasticsearch
    
    cd /var/log/elasticsearch (note: Do not delete vxfm-es-cluster.log)
    rm -rf *log.gz*
    rm -rf *gc.log*
    rm -rf *showlog.log*
    
    Systemctl start Elasticsearch
    sudo systemctl status Elasticsearch


3. Adım = ElasticSearch'teki TÜM verileri silin: 

*Uyarı: Müşteri tüm geçmiş uyarıları, kaynaklardan gelen performans ölçümlerini ve sistem günlüğü verilerini kaybeder.

 

  • curl -XDELETE localhost:9200/_all

 

Durumu kontrol edin ve rsyslog hizmetini durdurun.

 

systemctl status rsyslog

systemctl stop rsyslog

 

Tekrar deneyin ve sistem günlüğü hizmetini başlatın:

systemctl start rsyslog

 

 

Affected Products

PowerFlex rack, ScaleIO
Article Properties
Article Number: 000323551
Article Type: Solution
Last Modified: 19 Jun 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.