Data Domain: Jak zkontrolovat, který uživatel změnil plán čištění FS

Summary: Tento článek obsahuje informace o tom, kdo upravil plán čištění, spolu s podrobnostmi o uživatelích, kteří dříve spustili nějaké příkazy.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • V konfiguraci plánu čištění se zobrazí neočekávané změny
  • Plány čištění chybí, jsou upraveny nebo jsou spuštěny v nesprávnou dobu
  • Potíže s identifikací, kdo naposledy upravil plán 
  • Nedostatečný přehled o tom, který uživatel spustil konkrétní příkaz
  • Bylo zjištěno neobvyklé nebo neoprávněné spuštění příkazu

Cause

Standardní výstupy příkazu DD-CLI neposkytují žádnou informaci o tom, který uživatelský účet provedl relevantní změny.

Soubory protokolu však uchovávají podrobné informace o změnách provedených v plánu čištění. 

Resolution

1. možnost
 

1. krok: Přihlaste se do rozhraní příkazového řádku DD CLI jako uživatel admin.

 

2. krok: Vypíše protokoly.
 

sysadmin@localhost# log list
File          Size   Time Created
---------   ------   ------------------------
audit.log   12 KiB   Tue May 24 07:22:46 2025
messages    48 KiB   Tue May 24 07:30:37 2025
---------   ------   ------------------------

 

3. krok: Otevřete soubor audit.log v režimu správce.

log view audit.log

Při prohlížení protokolu procházejte soubor pomocí šipek nahoru a dolů. Ukončete program pomocí klávesy q. Zadejte lomítko pro vyhledávání vpřed nebo otazník pro zpětné vyhledávání "čistý plán".

Example:
May 11 21:40:47 lochost sshd[16324]: Failed password for invalid user isg-admin from 127.0.0.1 port 51851 ssh2
May 11 21:40:50 lochost sshd[16324]: error: Received disconnect from 127.0.0.1 port 51851:3: com.jcraft.jsch.JSchException: Auth fail for methods 'publickey,password,keyboard-interactive' [preauth]
/clean schedule

- Chcete-li zobrazit seznam všech položek, které obsahují "čistý plán" 

 

4. krok: Zkontrolujte výstup:

May 26 22:50:54 lochost sms: {epoch=1748325054;id='AUDIT-SMS_FILESYS-00035';desc='Set file system clean schedule.';level=1;user='sysadmin';role='admin';app='ddsh';host='127.0.0.1';client_ip='127.0.0.1';detail='{in='{sched='{hrs=6;min=0;days_mask=16;monthly='false';biweekly='true';}';}';result='Success';}';}
May 27 00:49:27 lochost sms: {epoch=1748332167;id='AUDIT-SMS_FILESYS-00035';desc='Set file system clean schedule.';level=1;user='dell';role='admin';app='-ddsh';host='127.0.0.1';client_ip='127.0.0.1';detail='{in='{sched='{hrs=6;min=0;days_mask=8;monthly='false';biweekly='false';}';}';result='Success';}';}

Vysvětlení výstupu:

Příklad výstupu ukazuje dva účty "admin" ("sysadmin" a "dell"), které potvrzují různé podrobnosti o plánu čištění (v rozmezí několika hodin).
 

2. možnost
 

K zobrazení souboru použijte sdílenou složku CIFS nebo export NFS do umístění /ddvar/log.  K zobrazení a prohledávání souboru použijte textový editor.  Klienti systému Microsoft Windows mohou používat editor, například Poznámkový blok.  Klienti se systémem Linux mohou používat nástroje příkazového řádku, například less a grep.

 Data Domain: Konfigurace sdílené složky CIFS

Data Domain: Připojení a ověření exportů v klientovi NFS

 

Linux (v Bashi)

Example
# grep -i "clean schedule" /ddr/var/log/audit.log*

- Chcete-li zobrazit seznam všech položek, které obsahují "čistý plán" 

 

Additional Information

Tento příkaz není omezen pouze na zobrazení historie plánu čištění. Umožňuje také určit, který uživatel spustil příkazy v systému DD:

Například:
Spustil jsem příkaz "data-movement policy show" ve zvýrazněném čase se secuser v časovém razítku: 28. května 01:14:41 IST 2025

Níže uvedený výstup příkazu zobrazuje čas a podrobnosti o uživatelském jménu, kdy byl spuštěn příkaz "data-movement policy show".  

 

 

Affected Products

Data Domain
Article Properties
Article Number: 000325581
Article Type: Solution
Last Modified: 04 Jul 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.