NMM Exchange non riesce a elencare i saveset

Summary: NetWorker Manager for Microsoft (NMM) Exchange non riesce a elencare i saveset. L'errore "L'interfaccia della shell di Exchange2010 non è inizializzata" viene visualizzato quando la password utente contiene caratteri Unicode. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Utilizzo di NetWorker Module for Microsoft (NMM) per configurare i backup di Exchange.

Utilizzo dello strumento di configurazione amministratore di Exchange NMM per configurare i backup. L'utente ha esito positivo, ma il tentativo di elencare i saveset ha esito negativo con il seguente errore:

Command line: C:\Program Files\EMC NetWorker\nsr\bin\nsrnmmsv.exe -v -P
169327:nsrnmmsv: Exchange2010 Shell interface is unavailable. This may indicate that the powershell library was not properly registered.

111867:nsrnmmsv:Exchange2010 Shell interface is not initialised.
145370:nsrnmmsv: Initialization error -- Exchange shell failed to initialize. Required for Exchange.

181314:nsrnmmsv:Unable to initialize Exchange Management Powershell with configured Exchange Backup Username. Validate the Exchange Backup User using NMM Exchange Admin Configuration tool before proceeding.
117296:nsrnmmsv: Failed to list supported save sets.

139524:nsrnmmsv: Unable to list save sets.

102333:nsrnmmsv: Exiting with failure.

 

Cause

NetWorker non è in grado di ottenere l'interfaccia PowerShell quando si utilizza una password con caratteri Unicode. Ad esempio: § 

L'interfaccia PowerShell è necessaria per eseguire il comando Exchange come Get-Mailboxdatabase ... E così via.

Resolution

Modificare la password dell'account utente per evitare caratteri Unicode. 

Affected Products

NetWorker Module for Microsoft
Article Properties
Article Number: 000325587
Article Type: Solution
Last Modified: 17 Jul 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.