NetWorker: El proceso de inventario de VMware falla "End of file or sin input: max message length exceeded"

Summary: NetWorker VMware Protection (NVP) está configurado en el entorno de NetWorker. Los flujos de trabajo de respaldo y los procesos de actualización de VMware fallan e informan lo siguiente: "Fin del archivo o sin entrada: se excedió la longitud máxima del mensaje" ...

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Symptoms

El daemon.raw del servidor NetWorker Server informa que el nsrvim El proceso falla con el mensaje "End of file or no input: max message length exceeded":

MM/DD/YYYY HH:mm:SS  1 3 0 536868608 40998 0 NETWORKER_SERVER_NAME nsrdisp_nwbg RAP notice job 'nsrvim' progress message: Querying for inventory at https://VCENTER_NAME/sdk 
...
MM/DD/YYYY HH:mm:SS  1 3 0 402650880 40770 0 NETWORKER_SERVER_NAME nsrdisp_nwbg RAP notice job 'nsrvim' progress message: End of file or no input: max message length exceeded

Los flujos de trabajo de respaldo de máquinas virtuales (VM) de NetWorker VMware Protection (NVP) fallan.

Cause

Este problema se plantea al departamento de ingeniería de NetWorker. Este problema se produce en vCenters grandes con 2000+ VM, aunque no existe un límite fijo, ya que depende de varios recursos de VMware más allá del conteo de VM. El inventario puede tener éxito con más de 2000 VM, pero pueden producirse problemas si se agregan o migran más recursos de VMware a vCenter.

 

Versiones de NetWorker afectadas:

De 19.9.0.x a> 19.12.0.x

Resolution

Las optimizaciones de código se incluyeron en el nsrvim y nsrdisp_vcentertaskmngr en NetWorker 19.13.0.0.

Actualice NetWorker Server a 19.13.0.0 (o superior).

Additional Information

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000326447
Article Type: Solution
Last Modified: 02 Sep 2025
Version:  9
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