NetWorker: O processo de inventário VMware apresenta falha "Fim do arquivo ou nenhuma entrada: comprimento máximo da mensagem excedido"

Summary: O NetWorker VMware Protection (NVP) é configurado no ambiente do NetWorker. Os fluxos de trabalho de backup e os processos de atualização VMware falham, relatando: "Fim do arquivo ou sem entrada: comprimento máximo da mensagem excedido" ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

O daemon.raw do servidor do NetWorker informa que o nsrvim o processo falha com "Fim do arquivo ou sem entrada: comprimento máximo da mensagem excedido":

MM/DD/YYYY HH:mm:SS  1 3 0 536868608 40998 0 NETWORKER_SERVER_NAME nsrdisp_nwbg RAP notice job 'nsrvim' progress message: Querying for inventory at https://VCENTER_NAME/sdk 
...
MM/DD/YYYY HH:mm:SS  1 3 0 402650880 40770 0 NETWORKER_SERVER_NAME nsrdisp_nwbg RAP notice job 'nsrvim' progress message: End of file or no input: max message length exceeded

Os fluxos de trabalho de backup de máquina virtual (VM) do NetWorker VMware Protection (NVP) falham.

Cause

Esse problema é levado à engenharia do NetWorker. Esse problema ocorre em grandes vCenters com 2000+ VMs, embora não exista um limite fixo, pois depende de vários recursos VMware além da contagem de VMs. O inventário pode ser bem-sucedido com mais de 2.000 VMs, mas podem ocorrer problemas se mais recursos do VMware forem adicionados ou migrados para o vCenter.

 

Versões afetadas do NetWorker:

19.9.0.x a> 19.12.0.x

Resolution

As otimizações de código entraram na nsrvim e nsrdisp_vcentertaskmngr funções no NetWorker 19.13.0.0.

Faça upgrade do servidor NetWorker para a versão 19.13.0.0 (ou posterior).

Additional Information

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000326447
Article Type: Solution
Last Modified: 02 Sep 2025
Version:  9
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.