PowerFlex: LDAP-Nutzer können sich nicht bei der PFMP-Benutzeroberfläche anmelden, wenn sie Teil der Gruppe "Protected Users" in AD sind
Summary: LDAP-Nutzer können sich nicht bei PFMP authentifizieren, wenn ihr AD-Konto Mitglied der AD-Gruppe "Protected Users" ist.
Symptoms
PFMP ist für LDAP konfiguriert und ein Nutzer, der Mitglied einer AD-Gruppe ist, die zu PFMP hinzugefügt wurde, kann sich bei der Anmeldung bei der Benutzeroberfläche nicht authentifizieren. Die Gruppe und der betroffene Nutzer sind im Keycloak sichtbar. Das AD-Konto des betroffenen Nutzers funktioniert ordnungsgemäß und die Kennwortzugangsdaten sind gültig.
Einige Nutzer, die Mitglieder derselben Gruppe sind, können sich möglicherweise problemlos bei der Benutzeroberfläche anmelden.
Keycloak-Pod-Protokoll (siehe keycloak-0 und keycloak-1):
2025-06-02 15:17:18,781 WARN [org.keycloak.events] (executor-thread-625) type=LOGIN_ERROR, realmId=9bfa2050-b67d-41b2-a6f9-20002994976c, clientId=compositeAdapter, userId=b1bbbe2f-a314-41d7-9e3b-68db0b162931, ipAddress=10.42.1.82, error=invalid_user_credentials, auth_method=openid-connect, auth_type=code, redirect_uri=https://slcpfx01fmp.enbridge.com/pfblock/dashboard, code_id=73b87c39-8c2d-4b94-885d-61b429ba0381, username=EB-STG3bansalp1-P
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Auswirkungen
Betroffene Nutzer können sich nicht über LDAP bei der PFMP-Benutzeroberfläche anmelden.
Cause
Der betroffene Nutzer ist ein Mitglied der AD-Gruppe "Protected Users". Diese Gruppenmitgliedschaft wirkt sich auf die normale LDAP-Authentifizierung und -Autorisierung bei der Anmeldung bei der PFMP-Benutzeroberfläche aus.

Resolution
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Entfernen Sie betroffene Nutzer aus der AD-Gruppe "Protected Users". |