PowerFlex: Gli utenti LDAP non possono accedere all'interfaccia utente PFMP quando fanno parte del gruppo Protected Users in AD
Summary: Gli utenti LDAP non sono in grado di eseguire l'autenticazione in PFMP se il loro account AD è membro del gruppo AD "Utenti protetti".
Symptoms
PFMP è configurato per LDAP e un utente membro di un gruppo AD aggiunto a PFMP non è in grado di eseguire l'autenticazione durante l'accesso all'interfaccia utente. Il gruppo e l'utente interessato sono visibili in Keycloak. L'account AD dell'utente interessato è in regola e le credenziali della password sono valide.
Alcuni utenti membri dello stesso gruppo potrebbero essere in grado di accedere all'interfaccia utente senza problemi.
Registro pod Keycloak (esaminare sia Keycloak-0 che Keycloak-1):
2025-06-02 15:17:18,781 WARN [org.keycloak.events] (executor-thread-625) type=LOGIN_ERROR, realmId=9bfa2050-b67d-41b2-a6f9-20002994976c, clientId=compositeAdapter, userId=b1bbbe2f-a314-41d7-9e3b-68db0b162931, ipAddress=10.42.1.82, error=invalid_user_credentials, auth_method=openid-connect, auth_type=code, redirect_uri=https://slcpfx01fmp.enbridge.com/pfblock/dashboard, code_id=73b87c39-8c2d-4b94-885d-61b429ba0381, username=EB-STG3bansalp1-P
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Impatto
Gli utenti interessati non sono in grado di accedere all'interfaccia utente PFMP utilizzando LDAP.
Cause
L'utente interessato è membro del gruppo AD "Utenti protetti". L'appartenenza a un gruppo influisce sulla normale autenticazione e autorizzazione LDAP durante l'accesso all'interfaccia utente PFMP.

Resolution
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Rimuovere gli utenti interessati dal gruppo AD "Utenti protetti". |