PowerFlex: LDAP-Nutzer können sich nicht bei der PFMP-Benutzeroberfläche anmelden, wenn sie Teil der Gruppe "Protected Users" in AD sind

Summary: LDAP-Nutzer können sich nicht bei PFMP authentifizieren, wenn ihr AD-Konto Mitglied der AD-Gruppe "Protected Users" ist.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PFMP ist für LDAP konfiguriert und ein Nutzer, der Mitglied einer AD-Gruppe ist, die zu PFMP hinzugefügt wurde, kann sich bei der Anmeldung bei der Benutzeroberfläche nicht authentifizieren. Die Gruppe und der betroffene Nutzer sind im Keycloak sichtbar. Das AD-Konto des betroffenen Nutzers funktioniert ordnungsgemäß und die Kennwortzugangsdaten sind gültig.

Einige Nutzer, die Mitglieder derselben Gruppe sind, können sich möglicherweise problemlos bei der Benutzeroberfläche anmelden.

Keycloak-Pod-Protokoll (siehe keycloak-0 und keycloak-1):

2025-06-02 15:17:18,781 WARN  [org.keycloak.events] (executor-thread-625) type=LOGIN_ERROR, realmId=9bfa2050-b67d-41b2-a6f9-20002994976c, clientId=compositeAdapter, userId=b1bbbe2f-a314-41d7-9e3b-68db0b162931, ipAddress=10.42.1.82, error=invalid_user_credentials, auth_method=openid-connect, auth_type=code, redirect_uri=https://slcpfx01fmp.enbridge.com/pfblock/dashboard, code_id=73b87c39-8c2d-4b94-885d-61b429ba0381, username=EB-STG3bansalp1-P
 

Auswirkungen

Betroffene Nutzer können sich nicht über LDAP bei der PFMP-Benutzeroberfläche anmelden.

Cause

 

Der betroffene Nutzer ist ein Mitglied der AD-Gruppe "Protected Users". Diese Gruppenmitgliedschaft wirkt sich auf die normale LDAP-Authentifizierung und -Autorisierung bei der Anmeldung bei der PFMP-Benutzeroberfläche aus.

 

Resolution

Entfernen Sie betroffene Nutzer aus der AD-Gruppe "Protected Users".

 

Affected Products

PowerFlex rack, ScaleIO
Article Properties
Article Number: 000342812
Article Type: Solution
Last Modified: 30 Jul 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.