PowerStore: Перевірка працездатності перед оновленням (PUHC) для виявлення системи метро 4.0.X із гучністю метро SYM, що застрягла в статусі синхронізованої БД

Summary: Під час неруйнівного оновлення (NDU) з PowerStoreOS 3.X до 4.0.X компоненти кластера, відповідальні за керування гучностями Metro, можуть зависнути в стані синхронізації (sync DB). Виникнення цієї проблеми не відразу впливає на середовище зберігання, однак, швидше за все, з часом виникнуть помилки введення-виведення, стрибки затримки або несподівані події HA, які потенційно можуть призвести до тимчасових проблем із доступом до даних. Ця перевірка працездатності перед оновленням (PUHC) призначена для виявлення цього стану та надання вказівок за потреби перед переходом NDU на PowerStoreOS 4.1. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Якщо PUHC виявляє одну або кілька гучностей метрополітену, що застрягли в «базі даних синхронізації», графічний інтерфейс PowerStore Manager відображає:

Екран відомостей про роботу

 

Вплив

Хоча ця умова не впливає безпосередньо на підключення на рівні хоста, вона може зрештою призвести до проблем із продуктивністю та доступністю, якщо її не вирішити.

Потенційні наслідки включають:

  • Помилки вводу/виводу
  • Стрибки затримки
  • Несподівані події високої доступності (HA)
  • Тимчасова недоступність даних на стороні хоста (DU)


Якщо проблему буде перенесено на подальше оновлення, її вирішення може вимагати ручного втручання, що збільшить операційну складність і потенційно вплине на доступність системи.

Cause

У PowerStore 4.0 з'явився внутрішній механізм синхронізації для підтримки постійних бронювань SCSI-3 для обсягів метрополітену.  Однак потенційний глухий кут або стан перегонів під час процесу синхронізації може призвести до того, що гучність метро залишиться в режимі sync_db.

Resolution

Постійне виправлення цієї проблеми планується випустити у версії PowerStoreOS 4.1.0.3

Спосіб вирішення:

У разі наявності або відсутності симптомів, що впливають на ситуацію, але до початку НДУ, цю проблему можна вирішити за допомогою наступних кроків

  • Використовуйте графічний інтерфейс PowerStore Manager, щоб призупиняти та відновлювати всі сеанси Metro невеликими групами з одного боку конфігурації метрополітену.  Ця дія спонукає PowerStore повторно вирівняти стан гучності метро.  Зверніть увагу , що немає необхідності зупиняти/відновлювати роботу з обох боків конфігурації метрополітену. 
  • У PowerStore Manager (GUI) знову запустіть PUHC, щоб переконатися, що проблему вирішено

Будь ласка, зверніться до служби технічної підтримки , якщо симптоми не зникають. 

Додаткові міркування:

Якщо NDU вже було розпочато, можливо, це може вплинути на системи через цю проблему.  Будь ласка, зверніться до KB 000328976 - PowerStore: оновлення до PowerStoreOS v4.1 може призвести до DU для конфігурацій гучності метро для отримання додаткової інформації.

Additional Information

Affected Products

PowerStore 1000T, PowerStore 1200T, PowerStore 3000T, PowerStore 3200T, PowerStore 5000T, PowerStore 5200T, PowerStore 7000T, PowerStore 9000T, PowerStore 9200T
Article Properties
Article Number: 000346226
Article Type: Solution
Last Modified: 03 Sep 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.