PowerStore: Verificação de integridade pré-upgrade (PUHC) para detectar o sistema metro 4.0.X com volumes metro SYM presos no status do banco de dados de sincronização

Summary: Durante um upgrade não disruptivo (NDU) do PowerStoreOS 3.X para 4.0.X, os componentes do cluster responsáveis pelo gerenciamento de volumes Metro podem ficar presos em um estado de sincronização (banco de dados de sincronização). A exposição a esse problema não causa impacto imediato no ambiente de armazenamento, mas é provável que eventualmente manifeste erros de E/S, picos de latência ou eventos inesperados de HA, resultando em problemas temporários de acesso aos dados. Esta verificação de integridade pré-upgrade (PUHC) foi projetada para identificar essa condição e fornecer orientação conforme necessário antes de um NDU para o PowerStoreOS 4.1. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Se o PUHC detectar um ou mais volumes metro presos em um "banco de dados sincronizado", a GUI do PowerStore Manager exibirá:

Tela Detalhes do trabalho

 

Impacto

Embora essa condição não afete imediatamente a conectividade no nível do host, ela pode eventualmente levar a problemas de desempenho e disponibilidade se não for resolvida.

Os impactos potenciais incluem:

  • Erros de E/S
  • Picos de latência
  • Eventos inesperados de alta disponibilidade (HA)
  • Indisponibilidade de dados temporária no host (DU)


Se o problema for transferido para um upgrade subsequente, a resolução poderá exigir intervenção manual, aumentando a complexidade operacional e potencialmente afetando a disponibilidade do sistema.

Cause

O PowerStore 4.0 introduziu um mecanismo interno de sincronização para dar suporte a reservas persistentes SCSI-3 para volumes Metro.  No entanto, um possível impasse ou condição de corrida durante o processo de sincronização pode fazer com que um volume metro permaneça preso em um modo sync_db.

Resolution

Uma correção permanente para esse problema deve ser lançada no PowerStoreOS versão 4.1.0.3

Solução temporária:

Na presença ou ausência de sintomas impactantes, mas antes de um NDU ser iniciado, esse problema pode ser corrigido com as seguintes etapas

  • Use a GUI do PowerStore Manager para pausar e retomar todas as sessões do Metro em pequenos volumes de um lado da configuração do Metro.  Essa ação solicita que o PowerStore alinhe novamente o estado do volume metro.  Não há necessidade de pausar/retomar em ambos os lados da configuração do metro. 
  • No PowerStore Manager (GUI), execute o PUHC novamente para confirmar se o problema foi resolvido

Entre em contato com o suporte técnico se os sintomas persistirem. 

Considerações adicionais:

Se um NDU já tiver sido iniciado, é possível que os sistemas sejam afetados devido a esse problema.  Consulte a KB 000328976 - PowerStore: o upgrade para o PowerStoreOS v4.1 pode resultar em DU para configurações de volume metro para obter informações adicionais.

Additional Information

Affected Products

PowerStore 1000T, PowerStore 1200T, PowerStore 3000T, PowerStore 3200T, PowerStore 5000T, PowerStore 5200T, PowerStore 7000T, PowerStore 9000T, PowerStore 9200T
Article Properties
Article Number: 000346226
Article Type: Solution
Last Modified: 03 Sep 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.