PowerStore. Диагностика системы перед модернизацией (PUHC) для обнаружения системы Metro 4.0.X с томами SYM Metro, зависшими в состоянии синхронизированной базы данных
Summary: Во время бесперебойного обновления (NDU) с PowerStoreOS 3.X до 4.0.X компоненты кластера, отвечающие за управление томами Metro, могут зависнуть в состоянии синхронизации (sync DB). Эта проблема не оказывает немедленного влияния на среду хранения данных, однако с большой вероятностью в конечном итоге она приведет к ошибкам ввода-вывода, скачкам задержки или неожиданным событиям высокой доступности, которые могут привести к временным проблемам с доступом к данным. Эта диагностика системы перед модернизацией (PUHC) предназначена для выявления этого состояния и предоставления необходимых рекомендаций перед выполнением бесперебойного обновления до PowerStoreOS 4.1. ...
Symptoms
Если PUHC обнаружит один или несколько томов Metro, зависших в «синхронизированной базе данных», в графическом интерфейсе пользователя PowerStore Manager отобразится следующее:

Воздействие
Хотя это состояние не влияет сразу на возможности подключения на уровне хоста, в конечном итоге оно может привести к проблемам с производительностью и доступностью, если его не устранить.
Возможные последствия включают:
- Ошибки ввода-вывода
- Скачки задержки
- Непредвиденные события с высокой доступностью (HA)
- Временная недоступность данных на стороне хоста (DU)
Если проблема будет перенесена на последующую модернизацию, для ее решения может потребоваться ручное вмешательство, что усложнит эксплуатацию и потенциально повлияет на доступность системы.
Cause
В PowerStore 4.0 реализован внутренний механизм синхронизации для поддержки постоянного резервирования томов Metro по протоколу SCSI-3. Однако потенциальная взаимоблокировка или состояние гонки во время процесса синхронизации могут привести к зависанию тома Metro в режиме sync_db.
Resolution
Окончательное исправление этой проблемы планируется выпустить в PowerStoreOS версии 4.1.0.3
Временное решение.
При наличии или отсутствии признаков неисправности, но до запуска бесперебойного обновления, эту проблему можно устранить, выполнив следующие действия
- С помощью графического интерфейса пользователя PowerStore Manager можно приостанавливать и возобновлять все сессии Metro небольшими группами с одной стороны конфигурации Metro. Это действие предложит PowerStore повторно выровнять состояние тома Metro. Обратите внимание , что нет необходимости приостанавливать/возобновлять работу с обеих сторон конфигурации Metro.
- В PowerStore Manager (графический интерфейс пользователя) запустите PUHC еще раз, чтобы убедиться, что проблема устранена.
Обратитесь в службу технической поддержки, если симптомы сохраняются.
Дополнительные факторы.
Если бесперебойное обновление уже запущено, возможно, что эта проблема может повлиять на работу систем. Дополнительные сведения см. в статье базы знаний 000328976 «PowerStore: модернизация до PowerStoreOS версии 4.1 может привести к недоступности данных для конфигураций томов Metro ».
Additional Information
Статья базы знаний 000214752 — PowerStore: Начальная страница для разделов «Проверки состояния системы, находящиеся на рынке вне выпуска»