PowerStore: Verificação de integridade pré-upgrade para identificar iniciadores sem host correspondente

Summary: Esta verificação de integridade avisa quando iniciadores FC Non-Volatile Memory Express (NVMe) (Fibre Channel) são zoneados e conectados ao equipamento PowerStore. No entanto, esses iniciadores não foram designados a um objeto Host correspondente. Embora rara, essa incompatibilidade pode gerar problemas no PowerStore, especialmente durante upgrades. Esse é um problema do PowerStore no primeiro dia e a melhor forma de atenuá-lo é com o zoneamento dos iniciadores NVMe-FC não utilizados. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Esta verificação de integridade pré-upgrade do PowerStore (PUHC) detecta iniciadores NVMe-FC conectados que não são designados como host correspondente no cluster: 

 

Impacto
Esse problema pode levar a uma falha de NDU (Non-Disruptive Upgrade, upgrade não disruptivo) e causar disrupções de serviço.

Cause

Um possível problema identificado no driver Fibre Channel qla2xxx pode causar uma pane no kernel do sistema durante upgrades não disruptivos (NDUs) ou reinicializações de módulo interno. A causa raiz é uma condição de corrida relacionada ao agendamento de exclusão de sessão, em que dois processos internos (del_work e rport_del_work) não têm sincronização adequada ao acessar recursos compartilhados. 

Resolution

  • Analise os iniciadores NVMe listados nos detalhes do PUHC.
  • Analise o ambiente de host e deszoneie esses iniciadores não utilizados ou crie um objeto de host, conforme apropriado.
  • Essa limpeza ajuda a evitar possíveis problemas e reduz o risco de problemas durante o NDU.

Consulte o artigo da base de conhecimento PowerStore: Hub de informações — documentação do produto e vídeos para documentação de configuração e conectividade do host.

Additional Information

Affected Products

PowerStore
Article Properties
Article Number: 000347818
Article Type: Solution
Last Modified: 23 Oct 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.