Rodbrugeren kan ikke logge på WebUI/CLI i 8.x, når standarddomænet er angivet

Riepilogo: Dubleret rodbruger i domænet forårsager problemer med at logge på klyngen via webbrugergrænsefladen og CLI.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Når du logger på klyngen, mislykkes enten via WebUI eller CLI med adgangskodefejl.

Dette gælder for OneFS 8.x, når der er en dubleret bruger (f.eks. rod) på domænet.

Du kan stadig logge på med det unix_users domæne:

UNIX_USERS\root

Kontroller, om det pågældende domæne er indstillet til standarddomænet:

#isi auth ads view --provider-name=<domain> --verbose | grep "Assume Default Domain"
    Assume Default Domain: Yes

 

Causa

Hvis standarddomænet er indstillet, kontakter OneFS først domænet for at godkende den pågældende lokale bruger. I dette tilfælde bruger vi root. Hvis brugeren findes på domænet, forsøger OneFS at godkende brugeren via domænet.

Hvis kontoen er deaktiveret, vises der en fejlmeddelelse, når du forsøger at logge på.

 

Risoluzione

I 8.x kan du tilføje brugere, der ikke kan findes, til enhver domænecontroller ved hjælp af følgende kommando:

# isi auth ads modify --provider-name=<domain> --add-unfindable-users=<list of users we don't want found(to include domain name and FQDN) --restrict-findable=yes

For at sikre, at indstillingerne er foretaget, skal du køre godkendelsesvisningen igen:

# isi auth ads view --provider-name=<domain> --verbose
--you are looking for this output:
         Unfindable Users: <FQDN>\root, <Domain>\root, 0, root
          Findable Groups: -
           Findable Users: -
        Restrict Findable: Yes

Hvis klyngen skal sikre, at den filtrerer de brugere, der ikke kan findes, fra, skal Begræns findbar være slået til.

 

Proprietà dell'articolo
Numero articolo: 000050102
Tipo di articolo: Solution
Ultima modifica: 17 apr 2026
Versione:  5
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.