Risoluzione dei problemi di accesso alle librerie a nastro in NetWorker

Riepilogo: Questo articolo ha lo scopo di aiutare il supporto e gli amministratori di NetWorker a determinare le cause dell'incapacità di un robot rilevato di accettare comandi.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

 

  • Impossibile accedere all'installazione della libreria a nastro rilevata sullo storage node o sul server NetWorker
  • Impossibile eseguire il backup dei dati a causa di hardware di backup inutilizzabile
  • Errori di accesso al robot:
    • 0x29
    • Device busy
    • The requested resource is busy
    • Str=<There is an input or output error.>
    • No such device
    • No such file or directory
    • Inappropriate ioctl for device

Causa

Se la libreria funzionava in precedenza e improvvisamente non lo è più, considerare l'ultima modifica nota come probabile causa:

  • Modifica non gestita dell'indirizzo della libreria dopo il riavvio, il nuovo rilevamento e la ridenominazione del dispositivo
  • Possibili danni dovuti a sovratensioni, interruzioni dell'alimentazione o altri eventi ambientali
  • Eventi di guasto o riconfigurazione dell hardware di trasporto
  • Installazione, modifica o eliminazione di software o driver relativi ai trasporti o alla robotica

Se la libreria non ha mai funzionato, verificare che l'hardware sia supportato nella NetWorker Hardware Compatibility Guide(richiede l'accesso all'account del supporto Dell). Ricorda che è possibile che una libreria sia parzialmente funzionale; Il rilevamento da solo non garantisce l'usabilità o il supporto.

Risoluzione

Per risolvere gli errori di accesso alla libreria, esaminare le modifiche recenti. Quindi utilizza test comparativi di base e di terze parti per confermare se un host o un processo può attivare una risposta da parte del robot.

A volte è auspicabile testare funzioni specifiche, sulla base delle evidenze disponibili. Se l'host A può interrogare il robot ma l'host B no, il robot è reattivo. L'autista dell'host A potrebbe bloccare il robot. Se l'host B continua a ricevere errori dopo che tutti gli host sono stati rimossi dalla suddivisione in zone, l'host B potrebbe avere un problema relativo a driver, configurazione o software.

Se l'host ha effettuato l'accesso al robot prima del problema, è molto probabile che gli elementi di revisione siano stati modificati. Analizzare gli errori o le modifiche alla configurazione note dopo l'evento.

Una volta rilevata la libreria, utilizzare i seguenti comandi per testare le operazioni SCSI di base sul trasporto di storage, non su Ethernet o sull'interfaccia utente web. Assicurarsi sempre che le patch del sistema operativo siano aggiornate, in particolare per quanto riguarda lo storage.

NOTA: Il modo più semplice per raccogliere un set di dati iniziale completo, inclusi i precedenti, consiste nell'eseguire nsrget -o:d sul server e sui nodi interessati.
ATTENZIONE: NON utilizzare il -o:d Su qualsiasi host con nastri in cui i nastri sono impegnati a scrivere. È possibile verificarlo da NetWorker Management Console (NMC) in Monitoring -> Devices.

L'articolo seguente fornisce informazioni su come ottenere e usare NSRGET: NetWorker: Come utilizzare lo strumento di data collection di NetWorker NSRGet (in inglese)


Accesso alla libreria: Sistema operativo:

  • Windows: Non esiste un modo nativo per eseguire query su una libreria a nastro in Windows. mtx ╚ un'utilità freeware che può essere testata se lo si desidera. Quando si emettono comandi viene utilizzato l'handle del dispositivo changer, anziché l'indirizzo SCSI (che può avere implicazioni di test).
loaderinfo -f \\.\changer#
mtx -f \\.\changer# inquiry
 
  • Linux: Come Windows, non dispone di un comando nativo per eseguire query, ma dispone anche di un mtx , che richiede l'handle del driver del dispositivo (ancora una volta, diverso dal modo in cui vi accede NetWorker).
loaderinfo -f /dev/sg#
mtx -f /dev/sg# inquiry
 
  • Solaris: Solaris include l'attributo sgen Driver per il supporto nativo della libreria a nastro, ma senza mtx non esistono altri comandi della libreria nativa per esso. Consultare invece la sezione sui comandi di NetWorker per testare l'accesso alla libreria (sotto).
     
  • AIX: AIX non dispone di alcun supporto nativo per le librerie a nastro (lus viene invece utilizzato) e non mtx La porta esiste per esso. Consultare invece la sezione sui comandi di NetWorker per testare l'accesso alla libreria (sotto).
  • HP-UX: mc è il comando nativo HP-UX per la manipolazione del medium changer:
mc -p $(ioscan  FnkC autoch | grep /dev/rac) -r MIDS -q
 
  • NetWorker: Questi comandi funzionano a un livello relativamente atomico e, sebbene siano scritti, compilati e testati dal supporto NetWorker, non richiedono un'istanza di NetWorker in esecuzione per funzionare, né alcuna configurazione di NetWorker. In generale, sono considerate utilità di test affidabili, di basso livello e indipendenti dal software. Per aumentare il debug per la maggior parte delle utilità, è possibile aggiungere le seguenti variabili di ambiente:

SJI_DEBUG=9
LUS_DEBUG=9 (lusdebug ffff on AIX)
CDI_DEBUG=9
SCSI_DEBUG=9
JBDEBUG=9

Di seguito, '<changer address>' varia in base al sistema operativo:

Windows: Initiator.Target.LUN (come rivelato da inquire comando) o \\.\changer# maniglia
del driverLinux: Intiator.Target.LUN (come rivelato da inquire comando) o /dev/sg# maniglia
del driverSolaris: /dev/scsi/changer/c#t#d# maniglia
del driverAIX: Initiator.Target.LUN (come rivelato da inquire comando)
HP-UX: Initiator.Target.LUN (come rivelato da inquire comando) o /dev/rac/c#t#d# Maniglia del conducente

sjirjc <changer address>
Richiede dati dal robot, come il numero di unità, le funzionalità supportate, ecc.

sjisn <changer address>
Richiede informazioni sull'elemento dell'unità e sul numero di serie al robot.

sjirdtag <changer address>
Richiede la cartuccia a nastro per i dati sulla posizione dell'elemento

cdi_inq -f <changer driver handle> -v
Richiede dati vitali sul prodotto (richiede l'utilizzo di una maniglia del driver)
 
ielem -a <changer address>
I tentativi di reinizializzare gli elementi possono causare interruzioni.
 

Accesso alla libreria: Reimpostazione della libreria:

Le librerie possono incontrare problemi periodici e transitori che causano loro problemi di ciclo di avvio; Diverse misure possono essere adottate per tentare di alleviare i problemi interni:

nsrjb -HEvvvvv
Esegue un comando di reimpostazione per una libreria problematica e forza la reinizializzazione di un elemento.

nsrjb -IIvvvvv
Forza l'aggiornamento e l'aggiornamento dell'object jukebox nsr di NetWorker in base ai codici a barre segnalati dalla libreria e ai valori corrispondenti nel database dei supporti.

nsrjb -HH
Forza il jukebox a scaricare tutti i volumi e a tentare un soft reset.
 
NOTA: I comandi di cui sopra funzionano solo in una fase successiva del flusso di lavoro, in particolare dopo che l'unità Libreria è diventata "Pronta" per accettare comandi. Pertanto, questa sezione fornisce solo i passaggi su come correggere potenziali problemi di "accesso" quando la libreria è nello stato "Ready". ielem -a è l'equivalente approssimativo di nsrjb -E che non richiede un jukebox nsr funzionale in NetWorker.
 

Trasporto - Configurazione

  • Per SAN: Assicurarsi che sia il robot che l'host di controllo del robot NetWorker previsto siano connessi correttamente allo switch e rivedere la suddivisione in zone del robot per assicurarsi che sia possibile una connessione end-to-end.
  • I robot non sono progettati per essere accessibili o controllati da più di un host; A meno che non sia necessario (ad esempio, un robot partizionato), assicurarsi che solo l'host del controller robot NetWorker previsto sia suddiviso in zone per la visualizzazione del robot.
  • E' possibile testare gli espansori SAS per assicurarsi che venga stabilita la connessione robotica; La tecnologia point-to-point pura, come SCSI, richiede il test della connessione dall'host pertinente.

Trasporti - Hardware

  • Se vengono rilevati problemi a livello di host o hardware di trasporto, è consigliabile testare lo switch o l'espansione o sostituire i cavi con esempi di "funzionamento noto" per escludere problemi di cablaggio.
  • Rivedi il firmware dell'hardware di trasporto e il firmware del robot stesso per la valuta.
  • Per SCSI, assicurarsi che i terminatori siano posizionati correttamente e posizionati saldamente, che i limiti di lunghezza dei cavi siano rispettati e che vengano utilizzate le tensioni appropriate.

Trasporto host - Configurazione

  • Assicurarsi che l'host interessato disponga di driver e firmware aggiornati per i driver di trasporto: utilizzare EMCReports (in bundle con nsrget -o:e).
  • Assicurarsi che qualsiasi configurazione del driver HBA (Host Bus Adapter) richiesta sia stata eseguita in modo appropriato per il sistema operativo.

Software host - Blocco delle risorse

  • Per qualsiasi host suddiviso in zone in modo da visualizzare il robot (idealmente, solo l'host NetWorker designato), verificare la presenza di software che potrebbero tentare di accedere al robot, ad esempio altri software di backup, software di monitoraggio o utilità standalone che potrebbero tentare di accedere al robot.
  • Per Solaris 10, il robot non è accessibile quando è collegato il processo NetWorker nsrlcpd; pertanto può sembrare inaccessibile (o addirittura non rilevabile) fino a quando la libreria in NetWorker non viene disabilitata (forzando nsrlcpd staccarsi e morire).
  • Se si sospetta che un processo non NetWorker blocchi o acceda al robot o a qualsiasi unità, consultare Risoluzione dei problemi relativi alle etichette sovrascritte e ai reset SCSI in NetWorker per ulteriori informazioni sulla risoluzione dei problemi e l'identificazione.

Se il sistema operativo rileva la libreria ma questa non risponde ai comandi, è funzionante in una certa misura. Potrebbe essere bloccato da un altro processo o host, interessato da problemi di trasporto o subire un malfunzionamento a livello di componente.

Se non è possibile determinare che nessun processo o host accede al robot oltre allo storage node NetWorker destinato a controllarlo, fare riferimento a Risoluzione dei problemi hardware della libreria a nastro in NetWorker per determinare se esiste un problema con il robot stesso.

Informazioni aggiuntive

Assicurarsi di comprendere che i problemi di robotica che si dimostrano non rientrare nell'ambito di NetWorker come applicazione (leggi: non è possibile accedervi utilizzando i metodi standard del sistema operativo) non rientrano nell'ambito del supporto di NetWorker.
Networker: Risoluzione dei problemi relativi alle librerie a nastro in NetWorker

Il supporto può fornire indicazioni utilizzando i criteri sopra indicati, ma non disponiamo di risorse di fornitori di sistemi operativi, HBA o robotica. Questa limitazione può causare una risoluzione dei problemi prolungata e non riuscita.

Prodotti interessati

NetWorker
Proprietà dell'articolo
Numero articolo: 000116098
Tipo di articolo: Solution
Ultima modifica: 23 gen 2026
Versione:  4
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