Impossibile installare il plug-in SSMS per Microsoft Application Agent
Riepilogo: Impossibile installare il plug-in SSMS per Microsoft Application Agent.
Questo articolo si applica a
Questo articolo non si applica a
Questo articolo non è legato a un prodotto specifico.
Non tutte le versioni del prodotto sono identificate in questo articolo.
Sintomi
Durante l'installazione di Microsoft Application Agent, viene visualizzato il seguente errore:
Il registro eventi dell'applicazione segnala anche il seguente errore:
Questo errore non impedisce la corretta esecuzione dell'application agent:
"There is a problem with this Windows Installer Package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor."
Product: Microsoft Application Agent -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action AddinReg, location: C:\Program Files\DPSAPPS\MSAPPAGENT\bin\, command: "C:\Windows\Microsoft.NET\Framework\v4.0.30319\RegAsm.exe" /codebase /tlb "C:\Program Files\DPSAPPS\MSAPPAGENT\bin\DDSSMSAddin.dll"
- I backup possono essere eseguiti dall'agent delle applicazioni.
- Gli script TSQ e della riga di comando vengono generati correttamente dall'agent delle applicazioni.
- Gli script TSQ copiati dall'application agent vengono eseguiti correttamente da SSMS.
Causa
La root cause è in fase di indagine.
Risoluzione
È possibile installare manualmente il plug-in dalla riga di comando. Per assicurarsi che il plug-in venga installato correttamente, verificare che SSMS non sia in esecuzione su questo host quando si esegue questo comando.
- Cliccare su Start e digitare cmd.
- Cliccare con il pulsante destro del mouse sull'oggetto del programma Prompt dei comandi e selezionare Altro, quindi cliccare su Esegui come amministratore.
- Passare al percorso della directory in cui si trova l'eseguibile VSIX.
- Ad esempio: C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE
- Questo percorso può variare leggermente in base al computer host.
- Disinstallare il VSIX corrente utilizzando questo comando di esempio:
- vsixinstaller /a /disinstallare:89089cd1-c652-42b2-8fd1-209e9ade1a2c
- Reinstallare VSIX utilizzando questo comando di esempio. Questo può variare in base al computer host.
- vsixinstaller /a "C:\Program Files\DPSAPPS\MSAPPAGENT\bin\plugin\NWSSMSVSIXPackage.vsix"
- Nota: Assicurarsi di modificare questo percorso se DDBMA non è installato nel percorso predefinito.
Nota: Il comando viene eseguito immediatamente, ma potrebbe verificarsi un ritardo di un paio di minuti. Dopo un po', sullo schermo appare la seguente casella:

- Cliccare su Install.

- Avviare SSMS per verificare che il plug-in sia installato in SSMS.

Prodotti interessati
Data Backup & Protection SoftwareProprietà dell'articolo
Numero articolo: 000193124
Tipo di articolo: Solution
Ultima modifica: 31 mar 2022
Versione: 1
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.