Data Domain: Interfaces Intel desativadas com tx_timeout

Riepilogo: Domínios de dados com links de interface de placas Intel podem ficar inativos com a recuperação tx_timeout sem sucesso, o dispositivo está em um estado irrecuperável.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Os logs de erros a seguir são encontrados no kern.info. 

kernel: [13023278.800638][T14886] (E4)irdma: probe of ice.roce.5 failed with error -110 
kernel: [13023278.800833][    C9] (E4)ice 0000:ae:00.0 eth8a: tx_timeout: VSI_num: 8, Q 41, NTC: 0x1bd, HW_HEAD: 0x1cb, NTU: 0x1cc, INT: 0x4000000 
kernel: [13023278.800834][    C9] (E4)ice 0000:ae:00.0 eth8a: tx_timeout recovery level 1, txqueue 41 
kernel: [13022896.344077][    C7] (E4)ice 0000:0b:00.0 eth2a: tx_timeout recovery unsuccessful, device is in unrecoverable state.

Você pode visualizar os logs do kern.info com o seguinte comando: 

log view debug/platform/kern.info

Você também pode verificar o pacote de suporte navegando até a plataforma e adicionando os logs de erro acima. 

Causa

Há um problema na irdma dentro do irdma_wait_pe_ready . Quando o RDMA está desativado no BIOS, a função realiza uma espera de rotação por até 15 segundos. Essa longa espera de rotação pode acionar paralisações de RCU, impedindo que algumas CPUs sejam agendadas para lidar com interrupções de TX e RX. Como resultado, as operações de transmissão e recebimento de NIC podem ter o tempo limite. Esse problema ocorre durante a fase de reinicialização do sistema.

Risoluzione

Faça upgrade para o DDOS 8.4 ou versões posteriores. 

A correção reduz a duração da espera de rotação de 15 para 1,5 segundo, eliminando o problema.

Prodotti interessati

Data Domain
Proprietà dell'articolo
Numero articolo: 000478096
Tipo di articolo: Solution
Ultima modifica: 16 giu 2026
Versione:  2
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.