Dell Unity:ViPRユーザーがRESTコールによるアレイへのログイン時に500エラーを受信する

概要: アップグレード後に、一時タイマーによる編集をcas-servlet.xmlファイルに適用します。 (Dell Correctable)

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

RESTとLDAPユーザーを使用するアレイにViPRログインすると、html 500コードが返される場合があります。

これは、Apache access_log (/nas/http/logs/access_log) で確認できます。

192.168.1.56 - - [31/Jan/2019 17:47:10.822820] 2469421 [31/Jan/2019 17:47:13.292241] "GET /cas/login;JSESSIONID=7CE46607BF48A30429EC6553EF94C785?username=<username>%40<domain>&password=<password><=LT-6519-gefNjJzSYRVfy1UuzSAwieHjBr9FCw-Unisphere&execution=e1s1&_eventId=submit HTTP/1.1" 500 1018 "-" "Apache-HttpClient/4.5.2 (Java/1.8.0_162)"
192.168.1.56 - - [31/Jan/2019 17:47:11.240570] 2871122 [31/Jan/2019 17:47:14.111692] "GET /cas/login;JSESSIONID=A2DA2D5AD53338F9AFA0EF6B6EB3CC36?<username>%40<domain>&password=<password><=LT-6520-eckw75hW7d1xzAe7HdRYG6VDIGbuO5-Unisphere&execution=e1s1&_eventId=submit HTTP/1.1" 500 1018 "-" "Apache-HttpClient/4.5.2 (Java/1.8.0_162)"

返された500ステータスは、サーバー側のエラーを示すため、Unityアレイで調査する必要があります。400の範囲のステータスはクライアント側のエラーと見なされ、アレイにコールを送信しているクライアントで調査する必要があります。

 

原因

この特定のケースでは、LDAPバインド応答にわずかな遅延があり、アレイのデフォルト値である5秒の範囲内でしたが、CASのWebセッション リスナーの別のデフォルトの2秒のタイムアウト値が原因でCAS(中央認証サービス)ログインが失敗しました。

 

解決方法

この問題は、Unityコード5.0.0.0.5.116以降で修正されています。以前のバージョンのコードを使用している場合は、5.0.0.0.5.116またはそれ以降のコードにアップグレードして、この問題を解決します。

 

その他の情報

このコンテンツは、次の言語に翻訳されています。 
https://downloads.dell.com/TranslatedPDF/PT-BR_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/AR-EG_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/DE_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/ES_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/FR_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/KO_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/JA_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/IT_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/NL_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/PT_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/RU_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/SV_KB530019.pdf

対象製品

Dell EMC Unity Family

製品

Dell EMC Unity Family
文書のプロパティ
文書番号: 000055413
文書の種類: Solution
最終更新: 25 2月 2026
バージョン:  5
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。