一部またはすべてのサービスが起動時に自動的に起動しない(LinuxまたはWindows)
概要: SRMサーバーの起動/再起動中に、一部またはすべてのサービスが開始されません。
この記事は次に適用されます:
この記事は次には適用されません:
この記事は、特定の製品に関連付けられていません。
すべての製品パージョンがこの記事に記載されているわけではありません。
現象
SRMサーバーの起動/再起動中に、一部またはすべてのサービスが開始されません。 サービスは、次の方法で正常に開始できます。
Linux SRMサーバーでスタートアップ スクリプト/etc/init.d/apg-serviceを使用して追加テストを行うと、statusコマンドも正しく機能しないことが分かります。「service agp-services status」は、開始に失敗したサービスを返しません。
'manage-modules.sh|manage-modules.cmd service start <module>'.
Linux SRMサーバーでスタートアップ スクリプト/etc/init.d/apg-serviceを使用して追加テストを行うと、statusコマンドも正しく機能しないことが分かります。「service agp-services status」は、開始に失敗したサービスを返しません。
原因
サービス起動モードが手動または無効に設定されました。
解決方法
[Centralized Management]->[Physical Overview]-[><SRM server>]-><[Collector]-[Manager Modules>で、[Configure Service]ボタンをオンにします。 [サービスのスタートアップ モード] が [自動] に設定されていることを確認します。
起動モードの設定を示す/opt/APG/Collecting/Collector-Manager/<collector-manager>/conf/service-user.propertiesファイルもあります。
cat service-user.properties #This file has been automatically (re)generated. #Fri Jul 29 12:24:02 EDT 2016 startup=manual
その他の情報
KB 000469626、Watch4net |EMCのM&R |ViPR SRM - LINUX SRMサーバーで追加チェックを行うために、サーバーの再起動後にサービスが自動的に起動しない(Linux)。
対象製品
SRM文書のプロパティ
文書番号: 000065756
文書の種類: Solution
最終更新: 29 7月 2025
バージョン: 4
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。