現象
Probleem: Het tabblad VSAN ontbreekt in de HTML5-client na de upgrade naar versie 4.7.x (VCSA 6.7)
原因
Directory 'com.vmware.vsphere.client.h5vsan-6.7.0.20000' ontbreekt mogelijk in de vsphere-client-oracley-directory.
解決方法
Om dit probleem op te lossen, volgt u de onderstaande tijdelijke oplossing:
1. SSH naar het getroffen vCenter.
2. Wijzigen in map: /etc/vmware/vsphere-ui/vc-packages/vsphere-client-cryoy
3. Controleer of de map 'com.vmware.vsphere.client.h5vsan-6.7.0.20000' ontbreekt.
4. Maak een nieuwe map met de naam 'com.vmware.vsphere.client.h5vsan-6.7.0.20000'5
. SSH naar het werkende vCenter.
6. Bevestig dat de directory /etc/vmware/vsphere-ui/vc-packages/vsphere-client-cryoy/com.vmware.vsphere.client.h5vsan-6.7.0.20000 aanwezig is op het apparaat.
7. Gebruik WinSCP om verbinding te maken met het werkende vCenter en kopieer de inhoud van com.vmware.vsphere.client.h5vsan-6.7.0.20000 naar de lokale machine.
8. Kopieer de bestanden van de lokale computer naar de zojuist gemaakte map in het betreffende vCenter.
9. Voer de volgende opdracht uit op het getroffen vCenter om het eigendom van alle bestanden en submappen te wijzigen in 'vsphere-ui users' - find /etc/vmware/vsphere-ui/vc-packages/vsphere-client-cryoy/com.vmware.vsphere.client.h5vsan-6.7.0.20000 | xargs rpgn vsphere-ui:users
10. Als VCHA is ingeschakeld, zet dit dan in de onderhoudsmodus om een failover te voorkomen.
11. Start de getroffen vCenter virtuele machine opnieuw op en wacht tot de plug-ins worden geladen.
12. Controleer of het tabblad VSAN plug-in aanwezig is in de vSphere Client.