現象
Issue : VSAN Tab is missing in the HTML5 Client post upgrade to 4.7.x version (VCSA 6.7)
原因
Directory 'com.vmware.vsphere.client.h5vsan-6.7.0.20000' might be missing in the vsphere-client-serenity directory.
解決方法
To resolve this issue, follow the workaround below:
1. SSH to the affected vCenter.
2. Change to directory: /etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity
3. Confirm that the directory 'com.vmware.vsphere.client.h5vsan-6.7.0.20000' is missing.
4. Create a new directory called 'com.vmware.vsphere.client.h5vsan-6.7.0.20000'
5. SSH to the working vCenter.
6. Confirm that the directory /etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity/com.vmware.vsphere.client.h5vsan-6.7.0.20000 is present on the appliance.
7. Use WinSCP to connect to the working vCenter and copy the contents of com.vmware.vsphere.client.h5vsan-6.7.0.20000 to the local machine.
8. Copy the files from the local machine to the newly created directory on the affected vCenter.
9. Run the following command on the affected vCenter to change the ownership of all files and subdirectories to 'vsphere-ui users' - find /etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity/com.vmware.vsphere.client.h5vsan-6.7.0.20000 | xargs chown vsphere-ui:users
10. Should VCHA be enabled, please put this into Maintenance Mode to prevent a failover.
11. Reboot the affected vCenter virtual machine and wait for the plugins to load.
12. Confirm that the VSAN plugin tab is present in the vSphere Client.