現象
Problem: Fanen VSAN mangler i HTML5-klienten efter opgradering til 4.7.x-version (VCSA 6.7)
原因
Mappen "com.vmware.vsphere.client.h5vsan-6.7.0.20000" mangler muligvis i vsphere-client-serenity-mappen.
解決方法
Du kan løse problemet ved at følge nedenstående løsning:
1. SSH til den berørte vCenter.
2. Skift til mappe: /etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity
3. Bekræft, at mappen "com.vmware.vsphere.client.h5vsan-6.7.0.20000" mangler.
4. Opret en ny mappe, der hedder "com.vmware.vsphere.client.h5vsan-6.7.0.20000"
5. SSH til det fungerende vCenter.
6. Bekræft, at mappen /etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity/com.vmware.vsphere.client.h5vsan-6.7.0.20000 er til stede på enheden.
7. Brug WinSCP til at oprette forbindelse til det fungerende vCenter og kopiere indholdet på com.vmware.vsphere.client.h5vsan-6.7.0.20000 til den lokale maskine.
8. Kopier filerne fra den lokale maskine til den nyoprettede mappe på det berørte vCenter.
9. Kør følgende kommando på det berørte vCenter for at ændre ejerskabet af alle filer og undermapper til "vsphere-ui users" - find /etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity/com.vmware.vsphere.client.h5vsan-6.7.0.20000 | xargswn vsphere-ui:users
10. Hvis VCHA er aktiveret, skal du sætte den i vedligeholdelsestilstand for at forhindre failover.
11. Genstart den berørte virtuelle vCenter-maskine, og vent på, at plugins indlæses.
12. Bekræft, at fanen VSAN-plugin findes i vSphere Client.
対象製品
VxRail Appliance Family
製品
VxRail Appliance Family