現象
Problème : L’onglet VSAN est manquant dans le client HTML5 après la mise à niveau vers la version 4.7.x (VCSA 6.7)
原因
Le répertoire « com.vmware.vsphere.client.h5vsan-6.7.0.20000 » peut être manquant dans le répertoire vsphere-client-serenity.
解決方法
Pour résoudre ce problème, suivez la solution de contournement ci-dessous :
1. Connectez-vous en SSH au vCenter concerné.
2. Accédez au répertoire : /etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity
3. Vérifiez que le répertoire « com.vmware.vsphere.client.h5vsan-6.7.0.20000 » est manquant.
4. Créez un nouveau répertoire appelé com.vmware.vsphere.client.h5vsan-6.7.0.20000'5
. Connectez-vous en SSH au vCenter en état de marche.
6. Vérifiez que le répertoire /etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity/com.vmware.vsphere.client.h5vsan-6.7.0.20000 est présent sur l’appliance.
7. Utilisez WinSCP pour vous connecter au vCenter en état de marche et copier le contenu de com.vmware.vsphere.client.h5vsan-6.7.0.20000 sur la machine locale.
8. Copiez les fichiers de la machine locale dans le répertoire nouvellement créé sur le vCenter concerné.
9. Exécutez la commande suivante sur le vCenter concerné pour modifier la propriété de tous les fichiers et sous-répertoires en « vsphere-ui users » - find /etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity/com.vmware.vsphere.client.h5vsan-6.7.0.20000 | xargs chown vsphere-ui :users
10. Si VCHA est activé, mettez-le en mode maintenance pour éviter tout basculement.
11. Redémarrez la machine virtuelle vCenter concernée et attendez que les plug-ins se chargent.
12. Vérifiez que l’onglet du plug-in VSAN est présent dans vSphere Client.
対象製品
VxRail Appliance Family
製品
VxRail Appliance Family